Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems with FFX
#1
Hello, im new here to the forum and the application itself.I've started using PCSX2 2 days ago to play some FFX, right after some brand new computer parts arrived.I usually get 60fps in some parts of the game but some others make my fps drop by half. This is very weird for i've seen people with same/lower specs than mines saying they'd get constant 60fps. Could someone help me? 

Specs:
Windows 10 Home 64-bit
Processor: AMD Athlon9tm0 X4 860K Quad Core 3.7 GHz
16 GB RAM
Graphics Card: Asus 5450 Silent 1GB DDR3

I use the most recent version of PCSX2.
Reply

Sponsored links

#2
Which parts of the game ?
What do the ee% & gs% say when it's slow ?
Playing from original disc ?
What are your pcsx2 settings ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
He is probably talking about areas like the beginning of mihen highroad where there is so much on screen that it used to slow down. Or even the effects for fire and demi. but I had thought that was fixed a while back.

Edit: Tho looking at that video card... That could be your bottleneck. specially if your trying to use higher then native resolution. My old 5830 had issues with this game too. Same with my 6770 from a few years ago. But that was back when demi still caused major slowdown.
[Image: dy6224-5.png]
Reply
#4
(01-07-2017, 08:08 AM)jesalvein Wrote: Which parts of the game ?
What do the ee% & gs% say when it's slow ?
Playing from original disc ?
What are your pcsx2 settings ?

Well it is exactly what the guy replied down there, with the attacks of demi and that part after the blitzball tournement.The thing is the ee% and gs% are at max 40% both, and this is rare. Im playing from the ISO and my settings are probably not the problem, for i used every type of different settings possible but didnt help.
Reply
#5
(01-07-2017, 01:07 PM)rikimaruaxu Wrote: He is probably talking about areas like the beginning of mihen highroad where there is so much on screen that it used to slow down. Or even the effects for fire and demi. but I had thought that was fixed a while back.

Edit: Tho looking at that video card... That could be your bottleneck. specially if your trying to use higher then native resolution. My old 5830 had issues with this game too. Same with my 6770 from a few years ago. But that was back when demi still caused major slowdown.

YES that's exactly it, but why tho? I thought 1GB would do just fine, and i can overclock mine till 1.3. Is it a problem from the AMD cards or i actually need a better card regardless of what i try?

When Rikku throws granades tho -_-
Reply
#6
it has to do with the way FFX renders scenes. To be completely honest with you I dont think its your card, But as i said i couldve sworn the demi lag was fixed. try messing with the skipdraw setting in GDSX I can't test it cause i dont have the ps2 version anymore. I have the pc version now.
[Image: dy6224-5.png]
Reply
#7
(01-07-2017, 11:59 PM)rikimaruaxu Wrote: it has to do with the way FFX renders scenes. To be completely honest with you I dont think its your card, But as i said i couldve sworn the demi lag was fixed. try messing with the skipdraw setting in GDSX I can't test it cause i dont have the ps2 version anymore. I have the pc version now.

Skipdraw, got it. Thanks man or girl idk, i'll do some tests now, and if possible come back after some time, if anything i might need further help that google cant provide Smile

Edit: Ok i looked at skipdraw settings and all that, im not really sure if that will affect my game much because i havent had a chance to try. The problem is not being caused by ghosting or anything, for instance, i just got to this part of the game and i cant bare with how ***** the fps is here, and this is on native. Look at ee% and gs%, something is very wrong here, please help

   

Edit2: So i looked further into the topic and found out that the 'Alow 8-bit textures' was the problem for me, and when i turned it off, the fps sky-rocketed Laugh. So the problem is half solved, can you explain me why 8-bit textures do that?
Reply
#8
I'm not the right person to explain it well enough. in my thinking its that demi and fire put so many textures on screen at once that it slows down. but someone more tech savvy when it comes to pcsx2 could explain better. in this case it seems like the cpu has an easier time rendering them then the gpu does

You could also try opengl instead of direct x, but amd has a rougher time with it then nvidia does so you may not see much increase
[Image: dy6224-5.png]
Reply
#9
(01-08-2017, 06:49 AM)rikimaruaxu Wrote: I'm not the right person to explain it well enough. in my thinking its that demi and fire put so many textures on screen at once that it slows down. but someone more tech savvy when it comes to pcsx2 could explain better. in this case it seems like the cpu has an easier time rendering them then the gpu does

You could also try opengl instead of direct x, but amd has a rougher time with it then nvidia does so you may not see much increase

I'll look it up later, but so far its been paradise with no more lags and no need to use SpeedHacks and anything. I'll just enjoy a bit for now, thanks for the help buddy, take care!
Reply
#10
There is FF HD for PC. I think you play that game no need ps2 version.
Reply




Users browsing this thread: 1 Guest(s)