Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Really Need Some Help
#1
Hi! I'm new to the forums! I have read and respected your rules, and will keep by them during my time here.


Anyways, I have issues with Socom 2, and Socom: Combined Assault.

My PS2 broke, so I took the game disks and made ISO's out of them on my computer. (They are not illegal that way, cause I bought the game, right?)
(I'm also aware that I can just use the disk, but I would like to keep my discs clean and away)

Firstly, I also did the same with the first Socom. (Socom 1 with Kahuna and Boomer)
That one works FLAWLESSLY! No graphical glitches, controls are great, etc.

But Socom 2 and Socom CA are pieces of crap in the missions, the menus are good. But one of the controls doesn't work properly. 

In Socom 2, It is a laggy mess.  And even when I do get decent FPS, the audio lags, it stutters at certain places. The text in cutscenes are just little white blocks.
It's very frustrating. Virtually UNPLAYABLE. WHich sucks cause this is probabaly my favorite Socom game aside from 1.

Meanwhile, Socom CA, plays great I would say. But it just goes all slow mo at certain parts of the missions. That normal? Nonetheless it's not terrible.

AN ISSUE WITH SOCOM 2 and CA:

The stance button, I can ONLY go prone and Standing.  While in Socom 1, I can go all 3 stances just fine. Did the ISO copy badly or what?  No matter how i press the button, the guy starts crouched, then he just goes prone. I press it again, he stands, Time after that, back to prone. It's impossible to have it crouched again. Makes it unplayable. 

My computer specs are:

Nvidia GTX 765m Graphics
8 GB Ram
2GB of video memory. 

I have an Asus Republic of Gamer's laptop. 

I have tried versions 1.0 and 1.2.1 of PCSx2. Here are the settings:


   

   

   



It is all just very frustrating. If anybody can help me out one problem at a time I would be so greatful! I specifically wanna know what the crouch issue is, then move into Socom 2's crappy performance. Any help is GREATlY appreciated.
Reply

Sponsored links

#2
welcome!

For a start I would turn those speedhack sliders right down! it can cause no end of problems, even introduce lag and alsorts, so turn those off and see how youi run then.

Did you change anything in the gamefixes tab?

Lastly make sure the emulator is using your nvidia card as it is a descrete card in your laptop, you can do this by making a profile for it in the nvidia control panel. Also make sure your windows power options are set to "high performance" or "maximum performance"
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
First fps issue.

Disable ee cyclerate hack and vcycle stealing der emulation settings.
Set internal resolution to native in gsdx plugin settings until we resolved the problem.
What are your fps, ee%, gs% and vu% values during slowdowns?

Second controller issue:

Please screenshot first and second tabpage in lilypad settings.
Reply
#4
(08-13-2015, 11:38 PM)refraction Wrote: welcome!

For a start I would turn those speedhack sliders right down! it can cause no end of problems, even introduce lag and alsorts, so turn those off and see how youi run then.

Did you change anything in the gamefixes tab?

Lastly make sure the emulator is using your nvidia card as it is a descrete card in your laptop, you can do this by making a profile for it in the nvidia control panel. Also make sure your windows power options are set to "high performance" or "maximum performance"


Okay, I'll try tunring the sliders down. How far down? All the way?

Also, no, no game fixes have been enabled, (I do not want to mess with things I do not know what they do.) If i should enable any, which ones?

And I will select my card and see how it goes, and yes it is set to "Power4 Gear High Performance."
Reply
#5
(08-13-2015, 11:41 PM)Destroyer123678 Wrote: I do not want to mess with things I do not know what they do.

Still you have enabled all speedhacks Tongue

No don't enable any manual gamefixes.
Reply
#6
Here is the ee% and stuf. It slightly helped. Although it is slowing down all-round. This is after i put the speedhacks down/changed it to my video card, and put it on native PS2 resolution. 

   



Here is my controller setup:
Further info: I am using a Steel Series USB controller. 

   


   
Reply
#7
FPS:
Try en/disabling mtvu. Where do you get better results?

I am not sure but I think you are still bottlenecked by the gpu. Have you made sure that pcsx2 is using the correct adapter?
Do you get slowdowns even if you stand still or only if you move around? Do you get slowdowns periodically or depending on the scene?


Control:
Can you please bind the movement to a keyboard control instead of your controller and check functionality?
Reply
#8
(08-14-2015, 12:01 AM)willkuer Wrote: I am not sure but I think you are still bottlenecked by the gpu. Have you made sure that pcsx2 is using the correct adapter?
Do you get slowdowns even if you stand still or only if you move around? Do you get slowdowns periodically or depending on the scene?

Would a 765m really be bottlenecking here? Is socom maybe one of gpu-demanding games? It's a bit more than an entry-level gpu
Reply
#9
(08-14-2015, 12:01 AM)willkuer Wrote: FPS:
Try en/disabling mtvu. Where do you get better results?

I am not sure but I think you are still bottlenecked by the gpu. Have you made sure that pcsx2 is using the correct adapter?
Do you get slowdowns even if you stand still or only if you move around? Do you get slowdowns periodically or depending on the scene?


Control:
Can you please bind the movement to a keyboard control instead of your controller and check functionality?



MTVU:

I get better results when it is on. Not by much at all though. On I get maybe 38- 48 it bounces around the ENTIRE time. With it on I'll get about the same, but it sticks to the lower range of fps.

Control: It didn't change anything. Still only prone and standing. :/
Reply
#10
FPS:
please provide the full emulog after you observed the problem

Control:
Keep using the keyboard until we solved the problem.
Please change ee and vu clamping modes to the lowest/most precise (Full, Full+Preserve sign or similar) values and check again. This will probably reduce your fps so put it back if it doesn't change anything or you are working on the fps problem.


@Rassane: maybe you are right but modern power saving features destroy human logic.
Reply




Users browsing this thread: 1 Guest(s)