Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
fps limit changing
#1
So my situation is a bit different then just having slow downs.

What happens is, after playing a game for X minutes (usually around 10+), the game suddenly slows down to 30 fps and won't speed back up until I close and restart pcsx2. (almost like the fps limit is now 30)

Enabling any number of speed hacks fail to resolve this.

When I run pcsx2, I don't keep any unnecessary programs running that could hurt my fps or hog ram.

Using beta.r1888
-Cpu options enabled except for microVU, fps set to Limit

-No speed hacks used or necessary, my laptop can run the game I'm trying to play at the moment around 200% until it slows down to 30 fps.

-Advances options at default, no game fixes necessary.

Plugins:
-GSdx 1873 (15.00, SSSE3) 0.1.15
Weave tff to stop screen shaking, 4:3 native, allow8, log. Z, alpha correct, and windowed enabled

-SPU2-X 1.2.0 with Defaults

-Linuz Iso CDVD 0.9.0

Computer Specs. are found in my signature, I'm using my Alienware laptop.
Intel C2D E8400@3.0Ghz | 2GB DDR2@800Mhz | NVIDIA GeForce 9800GTX 512MB | Asus P5N-D nForce 750i SLI Chipset | XP Pro SP3 | SuperPI 1.5-1m in 15.5s
Intel C2D T7600@2.3GHz | 2GB DDR2@665MHz | 2xSLI NVIDIA GeForceGo 7950GTX 512MB | XP Pro SP3 | Alienware Laptop | SuperPI 1.5-1m in 23s
Reply

Sponsored links

#2
Beta 1888 isn't supported anymore, try the 0.9.7 beta.

Seems like some kind of throttling in your machine, try checking with cpu-z if your cpu is running at same clock speed all the time. Try turning off Vsync if you have it enabled anywhere.
http://forums.pcsx2.net/Thread-PCSX2-off...ta-plugins
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
I tried using r1888 again while monitoring the cpu speed with cpu-z and nothing changed.

So then I tried with 0.9.7.3113 and got slowed down to 30 fps too, but a lot earlier. Again, no noticeable changes shown with my cpu.

I got the following errors with 9.7 while running the game. Shortly after, the game slowed down.

Issuing EE/iR5900-32 Recompiler Reset
microVU1: Cached MicroPrograms = [000] [PC=0000] [List=01] (Cache = 0.000000%)
microVU1: Cached MicroPrograms = [001] [PC=0006] [List=01] (Cache = 0.000000%)
microVU1: Cached MicroPrograms = [002] [PC=0008] [List=01] (Cache = 0.022305%)
DVCI: File cache was not hit. "¥MOVIE¥0001¥0010.SFD;1"
DVCI: File cache was not hit. "¥MOVIE¥0001¥0001.SFD;1"
DVCI: File cache was not hit. "¥MOVIE¥0001¥0002.SFD;1"
microVU1: Cached MicroPrograms = [003] [PC=0016] [List=01] (Cache = 0.025194%)
microVU1: Cached MicroPrograms = [004] [PC=004e] [List=01] (Cache = 0.071503%)
microVU1: Cached MicroPrograms = [005] [PC=0064] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [006] [PC=009b] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [007] [PC=00a2] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [008] [PC=00b2] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [009] [PC=00b9] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [010] [PC=00c8] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [011] [PC=0145] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [012] [PC=0139] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [013] [PC=00cf] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [014] [PC=00de] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [015] [PC=00e5] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [016] [PC=00f4] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [017] [PC=00fb] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [018] [PC=010a] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [019] [PC=0111] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [020] [PC=0119] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [021] [PC=0066] [List=01] (Cache = 0.117852%)
microVU1: Cached MicroPrograms = [022] [PC=0068] [List=01] (Cache = 0.117852%)

I'm playing Chaos Wars btw. :X
Intel C2D E8400@3.0Ghz | 2GB DDR2@800Mhz | NVIDIA GeForce 9800GTX 512MB | Asus P5N-D nForce 750i SLI Chipset | XP Pro SP3 | SuperPI 1.5-1m in 15.5s
Intel C2D T7600@2.3GHz | 2GB DDR2@665MHz | 2xSLI NVIDIA GeForceGo 7950GTX 512MB | XP Pro SP3 | Alienware Laptop | SuperPI 1.5-1m in 23s
Reply
#4
When using 0.9.7.3113 I also noticed that when the game slows down, the "EE:" on the top of the pcsx2 game window jumps from around 50% to 90%+.

Don't know what that means or if it has anything to do with it Tongue
Intel C2D E8400@3.0Ghz | 2GB DDR2@800Mhz | NVIDIA GeForce 9800GTX 512MB | Asus P5N-D nForce 750i SLI Chipset | XP Pro SP3 | SuperPI 1.5-1m in 15.5s
Intel C2D T7600@2.3GHz | 2GB DDR2@665MHz | 2xSLI NVIDIA GeForceGo 7950GTX 512MB | XP Pro SP3 | Alienware Laptop | SuperPI 1.5-1m in 23s
Reply
#5
Hmmm... more and more people report the same issue.
I will mention that this is the same thing that I and another person reported in a different thread. I did ask in that thread if this is worthy of posting it as a bug. Unfortunately I didn't get a response but I am getting closer to doing that anyway and risking the wrath of the mods...
Reply
#6
Quote:I tried using r1888 again while monitoring the cpu speed with cpu-z and nothing changed.

So then I tried with 0.9.7.3113 and got slowed down to 30 fps too, but a lot earlier.

If you are getting slowdowns in two different versions then It sounds like the problem is with your computer and not the program.

Quote:When using 0.9.7.3113 I also noticed that when the game slows down, the "EE:" on the top of the pcsx2 game window jumps from around 50% to 90%+.

That means your processor is the bottleneck.
Reply
#7
Quote:Hmmm... more and more people report the same issue.
I will mention that this is the same thing that I and another person reported in a different thread.
Are you by chance using a laptop?
Reply
#8
Then I wonder what I can do to fix this because my laptop never did this before, then I stopped playing on pcsx2 for a couple months and when I started again recently, this started.
Intel C2D E8400@3.0Ghz | 2GB DDR2@800Mhz | NVIDIA GeForce 9800GTX 512MB | Asus P5N-D nForce 750i SLI Chipset | XP Pro SP3 | SuperPI 1.5-1m in 15.5s
Intel C2D T7600@2.3GHz | 2GB DDR2@665MHz | 2xSLI NVIDIA GeForceGo 7950GTX 512MB | XP Pro SP3 | Alienware Laptop | SuperPI 1.5-1m in 23s
Reply
#9
It's Vsync. I'm sure of that.
Reply
#10
If its Vsync, what should I do to fix it? o.O
Intel C2D E8400@3.0Ghz | 2GB DDR2@800Mhz | NVIDIA GeForce 9800GTX 512MB | Asus P5N-D nForce 750i SLI Chipset | XP Pro SP3 | SuperPI 1.5-1m in 15.5s
Intel C2D T7600@2.3GHz | 2GB DDR2@665MHz | 2xSLI NVIDIA GeForceGo 7950GTX 512MB | XP Pro SP3 | Alienware Laptop | SuperPI 1.5-1m in 23s
Reply




Users browsing this thread: 1 Guest(s)