Install one of these first: DirectX End-User Runtime Web Installer (direct link), DirectX End-User Runtime (June 2010)

Then this one, too: Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)
And finally the Vista platform update which requires Service Pack 2 installed

Make sure you have at least Service Pack 1 for Windows Vista installed.

Latest revision: *link down* (on hold until gabest comes back, for the time being compile on your own)

Minimum requirements: Pixel Shader 2.0.

Recommended: DirectX 10 level video card, Windows Vista.

Note: SSSE3 is supported by the Intel Core 2 Duo, i3,i5 and i7 and by AMD Bulldozer FX series.
Note 2: SSE4 is supported by the Intel Core 2 Duo Penryn series or above,i3,i5 and i7 series. On the AMD side by the AMD Bulldozer FX series.

How to report a bug with a gs dump:
  • Go to a static scene in the game where not much is moving and the bug is visible.
  • Make sure it is not the spikey polygon syndrome.
  • Press SHIFT + F8.
  • In the snap folder of pcsx2 you will find a .gs file next to the .bmp.
  • Compress and upload them.
You can also replay the .gs file (it's only going to be two frames looping), run the following command:

rundll32 gsdx.dll,GSReplay <.gs file> (v1.5+)


rundll32 gsdx.dll,GSReplay <.gs file> (v1.7+)

Good for benchmarking too.

Previous versions:

GSdx9 0.10.0, GSdx9 0.10.2, GSdx9 0.10.3, GSdx9 0.10.4, GSdx9 0.10.5, GSdx9 0.10.6, GSdx9 0.10.7, GSdx9 0.10.8, GSdx9 0.10.9, GSdx9 0.11.0, GSdx9 0.11.1 (GSdx9 0.11.1a), GSdx9 0.11.2, GSdx9 0.11.3, GSdx9 0.11.4

GSdx10 0.1.0, GSdx10 0.1.1, GSdx10 0.1.2, GSdx10 0.1.3, GSdx10 0.1.4

GSdx 0.1.0, GSdx 0.1.1, GSdx 0.1.2, GSdx 0.1.3, GSdx 0.1.4, GSdx 0.1.5, GSdx 0.1.6, GSdx 0.1.7, GSdx 0.1.8 (7z), GSdx 0.1.9 (7z), GSdx 0.1.11 (7z), GSdx 0.1.12 (7z), GSdx 0.1.13 (7z), GSdx 0.1.14 (7z)



Latest revision: *link down* (on hold until gabest comes back, for the time being compile on your own)

Requirements: WinXP SP1+, XInput compatible controller (Xbox 360)

Previous versions:

xpad 0.1.0



Latest revision: *link down* (on hold until gabest comes back, for the time being compile on your own)

Note: dual layer not supported yet, iso file must have 2048 byte blocks.

Previous versions:

cdvd 0.1.0 (7z)


Donate via PayPal!

Sponsored links

Welcome to our forums, from all the pcsx2 playground staff Smile

And oh,I started moving out the thank yous to an appropriate thread, and also I'll delete/split useless things, like the one thousand asked "directx tells me to update" or "SSS3 on athlon" posts Smile hope I'll be able to clean the thread of useless things Smile
That was a quick reply.
Hi Gabest ,
I tried your plugin with Windows 7 beta 1 , (just was curious)
and I got the message "please update directx!",
which is a bit weird.
I guess we'll have to wait for win 7 support...
And have you tried updating it?
I just tried updating, and it worked .
Sorry for my fast conclusion.
(01-13-2009, 11:53 AM)Zriel Wrote: One question, I've got an AMD Phenom 9850 wich i'm quite sure supports SSE3 and I think SEE 4, but when I trie to use those modes, it's says my CPU doesn't run SEE3 or SEE4. Could you fix this please?
Oh, and in the emulator console, ( using both PCSX2 and PLayground) it says it supports SSE3, but not SSE4.1

The land of SSE is very confusing. I'll step you through slowly.

SSE & SSE2 - Easy ones. Most any modern CPU supports them!

SSE3 - a few instructions, none too impressive. Supported on P4's and above, and AMD64s and above.

SSSE3 - A special INTEL ONLY set of extensions to SSE3. Yes, it has a 3rd S. It's not a typo. Yes it's stupid to name it that. It was Intel's idea. No AMD chips support it that I know of. Maybe they don't like the name.

SSE4 - Minimally useful extension of SSEs introduced with one of the secondary versions of the Core2 line of Intel CPUs.

SSE4a - A mostly worthless "alternative" to SSE4, supported by AMD chips only (no Intel cpu supports these). Your Phenom supports SSE4a, but unfortunately it doesn't offer anything remotely useful to Pcsx2. It also lack all but the most useless of SSE4 instructions (SSE4 has 54 instructions, only 7 or 9 of which are in SSE4a)

SSE4.1 - Useful additions to the SSE instruction set, but only Intel CPUs support them so far (newer Core2's).

SSE4.2 - New instructions offered by the i7, and again nothing to exciting here from a Pcsx2 standpoint.

So yeah, your CPU supports SSE3 (not SSSE3!) and SSE4a (not SSE4!) instructions, but unfortunately neither of them are very useful to Gsdx. So you're stuck using SSE2.
(01-13-2009, 12:20 PM)Air Wrote: SSE3 - a few instructions, none too impressive. Supported on P4's and above, and AMD64s and above.
SSE3 is only available on later AMD64 CPUs.
My good old S754 Newcastle supports SSE2 only and lacks segmentation in 64Bit mode (needed by vmware for 64Bit virtualization).
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Just wanted to report

The Jade Cocoon 2 movies are playing in a black screen (sound runs normally), they work fine on zerops though. So its definitly a gdsx bug.
Fighting for peace is like ***** for virginity ...

Failure is not an option | It is bundled with your Microsoft product
Hey Gabest I was wondering if you could take a look at skygunner? It works fine on zeroGS (although really slowly Wink

With gsdx, it causes all sorts of havoc...bsod, all programs hanging then dieing, etc...
Hi Gabest! I'm impessed your work and got some questions for you.
At fist, are you used your own hand-writed software rasterizator or it's a custom version of allready exist DX emulator with some modified stages for best accurate. I ask it couse your plugin works even better(much less bugs) on software mode. And as i know you use tile like render(or scanline), can it be acellerated by CUDA/OpenCL? or it need more expensive store than 16kb in allready exist DX10 NV chips(As i know it have good banwith but horrible latency, and i don't realy know can it be used for programs task or it just for sync threats?) Maybe software render with implemet of CUDA code for filter and blending be the best case?(much of fps goes down in scenes with bangs in FFXII, but at all your software is very fast compared to others raster emulators) And in FFXII has problems with shadow maps on hardware and faces of low-poly ver of models(line, only at DX10 hardware), line is lost without filtering. Do you use fixed pipe(texture filtering blocks) for filter or do it by shaders?
PS: Sorry for my EnglishBlush
Gabest, please add these alternatives to the CRC list:
{0x280AD120, FFXII, JP, false},
{0xC5DEFEA0, Okami, JP, false},
{0x0481AD8A, MetalGearSolid3, JP, false},
{0xB01A4C95, ICO, JP, false},
{0xAEAD1CA3, GT4, JP, false},
{0x5ED8FB53, AceCombat4, JP, false},
{0xFC46EA61, Tekken5, JP, false},
{0x565B6170, WildArms5, JP, false},
{0xA5768F53, GiTS, JP, false},
Puzzle of the day, the visual c optimizer:

66 0f 38 30 94 24 30 01 00 00 pmovzxbw XMMWORD PTR _c$195711[esp+400], xmm2
66 0f 6f 84 24 30 01 00 00 movdqa xmm0, XMMWORD PTR _c$195711[esp+400]

Who can tell what's wrong there?

Users browsing this thread: 6 Guest(s)