Having trouble building on chroot
Hi. I've downloaded sources. I'm running Debian Wheezy, but really I have no idea how to get cross compiling working, so I set up an i386 chroot. I have installed cmake, gcc, g++. However when I run build.sh I get this error:
Quote:CMake Error at CMakeLists.txt:21 (message):
PCSX2 does not support a 64-bit environment. Please install a 32-bit chroot or a 32-bit OS.
PCSX2 has no plan to support a 64-bit architecture in the future.
It would need a complete rewrite of the core emulator and a lot of time.
However, when linux distribution properly supports multi-arch packages, it will
be at least possible to easily compile and install PCSX2 without too much hassle (the chroot environment).

-- Configuring incomplete, errors occurred!
./build.sh: 73: ./build.sh: make: not found
./build.sh: 74: ./build.sh: make: not found

The chroot is i386, so what's the problem? Unless I got the architectures wrong?

Sponsored links

Make is separate program from CMake. So you have to install Make as well. If I remember correctly Debian does not give you Make by default but you can get it from the repositories.
Hum, I suggest to get latest source from svn (isn't it the goal of self compiling Wink ). The cmake error will be downgraded to a warning.

You can build PCSX2 on a 64 bits debian if you setup multiarch properly.
I installed make, but still got the same. I got the source from download section --> source code. And what is this svn? Isn't it for windows? Thanks.
SVN is where the latest and greatest builds are placed when they are updated. Just put this in your terminal. Exact OS is not important.

svn checkout http://pcsx2.googlecode.com/svn/trunk/ pcsx2-read-only

Then of course the ./build.sh command.

It may or may not compile as it is fussy about checking all dependencies. You will need multiarch enabled which is not default in Debian. Try this command. You may need to be superuser.

dpkg --add-architecture i386

It's been awhile since I compiled but it seems like it doesn't want to cooperate anymore. Since I already have PPA installed I though I could get dependencies from it like I used to do for SVN compiling but it gives me dependency hell instead, and the further along I go in multiarch it wants to remove a bunch of programs.

Attached is my terminal log on Mint 14 (Ubuntu-based) 64bit.

On a side note, the PPA hasn't been updated since early November when GSdx had that AMD GPU crash, so all I have working since is ZZogl. Now SVN don't compile either...

Attached Files
.txt   compile_attempt.txt (Size: 25,4 KB / Downloads: 523)
I have already added the architecture before to intall some libs that weren't available in amd64. But it seems like cross compiling is a lot more complicated. So I prefer to install it as chroot. I have went from dependency hell before and made it, but well every dependency hell is different.

How do I download this source? Can I download an entire directory using wget for example or some other automated way?
use the svn checkout command listed above. it is similar to wget. you may need to install subversion from repository first.
Thanks that kinda worked. Now I got to go through this dependency hell you mentioned. I will update my post later.

Edit: It needs gtk2 libraries. So I need to install gtk2.0 right? This is a 1.2GB meta package. I can delete it after compilation is succesfull anyway. But I want to make sure I'm not wasting my time installing package this size.
yep you need gtk2. i am not sure how much of that extra stuff is useless or necessary
to elaborate on my earlier post i also have ppa installed. i tried to use sudo apt-get build-dep pcsx2-unstable:i386 to get dependencies off the ppa like i used to. it has been a few months since i did that and it doesnt seem to work anymore as packages change.

Users browsing this thread: 1 Guest(s)