Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How do I use my GPU when using OpenGL?
#1
The Sly Cooper games run like absolute garbage with OpenGL, often dropping down to 30% gamespeed even with Blending Unit off.  This is a shame because many important visual effect such as shadows and Sly 3's 3D mode only render with OpenGL.

I recently got a new gaming computer, this thing is currently the best money can buy.  It's overkill:

- Intel Core i9-10900K

- NVIDIA RTX 2080 Super

- 64 GB DDR4 memory

There was absolutely no way the games could experience slowdowns on OpenGL using this build.  Nope!  The Sly Cooper games all slow down to 30% gamespeed when using OpenGL.  This is when I noticed that the GPU selection got grayed-out when OpenGL was selected.  It's not using my GPU, that's probably the cause of the slowdowns.  Is there any way to use my GPU and OpenGL at the same time, even if it's a hacky unofficial method?
Reply

Sponsored links

#2
a driver issue, maybe ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
The gpu selection should be grey out when using opengl.
OS: Windows 10 Home 64 BIT 20H2
CPU: AMD R7-3700X 3.6 GHZ
GPU: Asus GeForce GTX 1650 Super
RAM: Corsair 3600 MHZ 2x8GB DDR4
Mainboard: Gigabyte B450 PRO WIFI
Display: Asus VP228
Audio: Creative Sound Blaster Z / GigaWorks T40
Storage: Seagate 1TB HDD, Transcend 1TB SSD
Optical: Asus BW-16D1HT Blu-Ray Writer
Power supply: Corsair CX550M
Reply
#4
Are you sure it's not using the gpu, did you check gpu usage?
Sly 2 and 3 can bring any gpu to it's knees.
You might want to run the latest dev builds as we fixed a performance issue on OpenGL which heavily affects Sly games.
CPU: I7-4770 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5 / GTX750TI [b]2GB GDDR5

OS: Windows 10 Pro 64bit
[/b]
Reply
#5
Okay, I set up the most recent 1.7.0 build and tried again. Still getting the same massive slowdowns when using OpenGL.

Also, why make such drastic changes to the UI? This is going to be a major pain in the rear end to get used to.

Edit: I checked - it's using 95%-100% of my GPU at all times. If it uses 100% of an NVIDIA RTX 2080 Super, what kind of GPU would I need? Probably one that won't exist for the next few decades. Also, while I was typing this edit, it dropped down to less than 1 FPS. If I use Direct3D11 in that very same scene, it uses no more than 35% of my GPU, and I can disable the framelimiter allowing it to run at 300+ FPS.
Reply
#6
DX has a crc hack that skips some effects, also it doesn't support proper blending. Set crc to none if you want it to skip less(will help render some map shadows) and set blending option to high on dx.
CPU: I7-4770 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5 / GTX750TI [b]2GB GDDR5

OS: Windows 10 Pro 64bit
[/b]
Reply
#7
I set it to Direct3D11, CRC Hacks to None, and Blending Unit to High. Still not rendering shadows. Is this an NVIDIA issue?
Reply
#8
Like I said it will render some shadows (make the stage a bit darker as it should) and not character shadows for example.
It's not very noticeable if you're not comparing differences.
CPU: I7-4770 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5 / GTX750TI [b]2GB GDDR5

OS: Windows 10 Pro 64bit
[/b]
Reply




Users browsing this thread: 1 Guest(s)