Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shaders are not working
#1
1.Place the shader.fx in the pcsx2 directory
2.Press PgUp to enable it

That's the way right?

It was couple of mounts the last time I used pcsx2(not to mention shaders)and now for some reason,loading the shader(PgUp)have absolutely no effect...it does the same thing as if I don't have shader.fx in the pcsx2 directory.

The only difference between before and now on my pc is that I use the newest video drivers(I was with 84.21 before when it worked)

The shader is supposed to increase the gama(make it more visible on dark games)

I'm I doing something wrong(forgetting to do something)
I'm using 1.0.0 with the official plugins


Attached Files
.rar   shader.rar (Size: 492 bytes / Downloads: 101)
Reply

Sponsored links

#2
Is emulog show shader error?
Im sorry i often misstype because im using cellphone...Y( '',)Y
Reply
#3
I don't even renumber if the console is supposed to show anything related to the shaders

I don't see anything in the console that says it's loading shader.fx and when I press PgUp,I get
GSdx: fxaa is now enabled.

I also tried some other shaders from here but I don't see any effect...just what FXAA do when no shader.fx exist
Reply
#4
Should see this in the console window if it works correctly "GSdx: Post-processing shader is now enabled."

Do you also have this file in the same folder? "External shader.patch" Here is a link to the file needed http://www.mediafire.com/download/bbhho6...2BFXAA.zip
Reply
#5
(09-30-2013, 12:26 PM)Topken Wrote: Should see this in the console window if it works correctly "GSdx: Post-processing shader is now enabled."

I get this if I use some newer GSdx rev(for example 5464)but I still don't see any change.
It was working fine before.

Just to be sure...does pcsx2 1.0.0 with his plugins support shaders?

PS.I don't have those files from the archive and I didn't need them the last time I used shaders(the .patch file will not do anything when I place it in the pcsx2 folder,that file is patching gsdx files before compiling it)
Reply
#6
Try the cell shader and see if you see any results with that one. IT should give you the most visual change so you can check if its loading or not
Reply
#7
GSdx included with 1.0.0 didn't had this feature yet, forgot when exactly it was added but any new GSdx from buildbot should handle it. And your shader works fine, it returns one warning:
Code:
warning X3571: pow(f, e) will not work for negative f, use abs(f) or conditionally handle negative values if you expect them
but this can be safely ignored since "f" is actually a color in that shader;p.
Reply
#8
Still nothing...just tried the latest pcsx2 and gsdx beta and still no effect.
The console says
GSdx: Post-processing shader is now enabled.
but the effect is exactly the same as if shader.fx doesn't exist in the pcsx2 folder

I didn't make that shader,KrossX did and it worked fine the last time I used it.
As a side note(if it matters)shaders on ppsspp are working fine
Reply
#9
See if this one changes the visuals http://forums.pcsx2.net/attachment.php?aid=31046 if it does then its loading the shader correctly if not then there is a problem
Reply
#10
Weird...no idea what I did but now it decided to work
Reply




Users browsing this thread: 1 Guest(s)