Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Software mode runs a lot slower after 1.3.1.1415
#41
(12-09-2015, 06:59 AM)Dr_Hycodan Wrote: Yes, no hyper threading works

I'll even give you options to choose on Tongue2 = you can reply the respective number and choose the one which you intended to mention.

1/ disabling Hyper Threading solves the issue.
2/ enabled Hyper Threading and the issues is gone, YAY ! Laugh
3/ the issue could be reproduced at random instances.
4/ Hyper threading works... but PCSX2 doesn't Sad


@jes && @blyss

maybe he's not good with english ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction
Reply

Sponsored links

#42
(12-09-2015, 08:02 AM)Blyss Sarania Wrote: Well I take his most recent post as an honest answer, I think the ambiguous wording was unfortunate rather than intentional. Call me naive Tongue2
I wouldn't even dare to do so.
Let's say "optimistic person" Tongue2
Quote:However he is the only active person with an i7 skylake and it does appear to be a real issue. Others have reproduced it only to disappear before we can get them to test. So if he can provide good test results then I guess the thread should stay.
seeing how it's hard for him/her to make proper sentences, I guess we can keep waiting for those tests Laugh
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#43
hmm, OP reminds me of this person : http://forums.pcsx2.net/Thread-PS2-logo-...#pid210406

probably coincidence that they have same birthday...

either way I'm not sure what would be the optimal fix if the issue is due to skylake hyperthreading.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction
Reply
#44
Anybody can confirm this is fixed in latest git?
Reply
#45
A confirmation will be nice as we might drop vs2013 support this year
Reply
#46
I have a skylake 6700K CPU running 4.0GHz

Prior to the recent fix (by Jonathan Li?), the framerate always fluctuate a lot when setting Rending threads > 0 without any performance gain as someone mentioned in Github. It happens no matter hyper threading is enabled or not. For info, the vs2013 was working fine with extra thead > 0.

Last night I tested v1.5.0-dev-1774-g3fab287 (vs2015) with Steambot Chronicles in OpenGL software mode. The stutter is gone and it seems to be identical to the vs2013 build.

I used the same scene to test with and without HT:

HT Disable (4 cores 4 threads)
MTVU off, Extra thread = 0, fps = 46
MTVU off, Extra thread = 2, fps = 75 - 78

HT Enabled (4 cores 8 threads)
MTVU off, Extra thread = 0, fps = 45
MTVU off, Extra thread = 2, fps = 75

Many thanks to the PCSX2 team for keep looking into this issue since late 2015. Brilliant Job <3

Edited: Hyper Threading results included.
Reply
#47
Cool! Thank you.
If only Sarania was this patient ‎Laugh
Reply
#48
Feel a bit guility about not helping and posting my test results to the Github issue thread. Hopefully this confirmation made up for it Smile
Reply




Users browsing this thread: 1 Guest(s)