Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solved: Can't use OpenGL on recent builds
#1
Hi, I recently installed a bunch of the most recent versions of PCSX2(the 2567 and 2571 builds) and I noticed I cannot use the OpenGL renderer(software and hardware). It's odd because before I downloaded the most recent versions, I used one from may(2379) and in that one, I'm able to use OpenGL and pick an Adapter. The graphical plugin is SSE2. I've tried with SSE4.1 but the result is the same. I cannot use AVX2 because my CPU doesn't support it(i5-3570K).

My drivers are up to date(AMD Radeon Software Adrenalin Edition 18.9.3; AMD R9 280), reinstalled, clean installation(DDU) with no errors whatsoever. Windows up to date, too, AFAIK.

As I said, if I just open the older May build I'm able to use OpenGL, but if I use most recent build I'm not able to pick an Adapter on OpenGL or use it, whatsoever.
Reply

Sponsored links

#2
Sounds like amd's ***** drivers problem again...

Reverting to older GPU drivers could be a good thing to try
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(09-30-2018, 03:27 PM)jesalvein Wrote: Sounds like amd's ***** drivers problem again...

Reverting to older GPU drivers could be a good thing to try

I think that didn't work out. I can stil use OpenGL on the older PCSX2 version, but I cannot do it on any of the most recent versions.

On the newer drivers, 18.9.3, the OpenGL version is 24.20.11000.13541. I also tried the previous 18.9.1 drivers, but it didn't work out.
Reply
#4
(09-30-2018, 03:14 PM)Clothesline Wrote: Hi, I recently installed a bunch of the most recent versions of PCSX2(the 2567 and 2571 builds) and I noticed I cannot use the OpenGL renderer(software and hardware). It's odd because before I downloaded the most recent versions, I used one from may(2379) and in that one, I'm able to use OpenGL and pick an Adapter. The graphical plugin is SSE2. I've tried with SSE4.1 but the result is the same. I cannot use AVX2 because my CPU doesn't support it(i5-3570K).

My drivers are up to date(AMD Radeon Software Adrenalin Edition 18.9.3; AMD R9 280), reinstalled, clean installation(DDU) with no errors whatsoever. Windows up to date, too, AFAIK.

As I said, if I just open the older May build I'm able to use OpenGL, but if I use most recent build I'm not able to pick an Adapter on OpenGL or use it, whatsoever.

If I am interpreting this correctly, the problem is that the adapter selection is gone. This is actually by design and not broken. With OpenGL, adapter selection is done automatically in the background, so there is no point in having an adapter selection to confuse users. Is it no longer able to launch a game? Or is it just the blank selector field that had you concerned?
Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#5
[Image: 1538325832-snap-screen-20180930184317.png]
Latest build + latest drivers (but i own an NVIDIA card...)
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
Photo 
(09-30-2018, 06:41 PM)pandubz Wrote: If I am interpreting this correctly, the problem is that the adapter selection is gone. This is actually by design and not broken. With OpenGL, adapter selection is done automatically in the background, so there is no point in having an adapter selection to confuse users. Is it no longer able to launch a game? Or is it just the blank selector field that had you concerned?

(09-30-2018, 06:44 PM)jesalvein Wrote: Latest build + latest drivers (but i own an NVIDIA card...)

When I choose the OpenGL renderer, when I boot the game, it is not using OpenGL(HW or SW mode). Even if I go into video settings while the game is running and pick OpenGL, it won't use it. I'm only able to use D3D11/9.


[Image: mKaqHDx.png]
Reply
#7
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
(09-30-2018, 07:23 PM)jesalvein Wrote: Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
Code:
[code]
PCSX2 1.5.0-20180928023358 - compiled on Sep 28 2018
Savestate version: 0x9a0d0000

Host Machine Init:
    Operating System =  Microsoft Windows 10 Pro (build 17134), 64-bit
    Physical RAM     =  8077 MB
    CPU name         =  Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
    Vendor/Model     =  GenuineIntel (stepping 09)
    CPU speed        =  3.398 ghz (4 logical threads)
    x86PType         =  Standard OEM
    x86Flags         =  bfebfbff 7f9ae3bf
    x86EFlags        =  28100000

x86 Features Detected:
    SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX

Reserving memory for recompilers...

Loading plugins from C:\Users\Jorge\Desktop\PS2\pcsx2-v1.5.0-dev-2571-ge90c87a8e-windows-x86\plugins...
    Bound   GS: GSdx32-SSE4.dll [GSdx 20180928023358 (MSVC 19.00 SSE4.1/AVX) 1.1.0]
    Bound  PAD: LilyPad.dll [LilyPad (20180928023358) 0.12.1]
    Bound SPU2: Spu2-X.dll [SPU2-X 20180928023358 2.0.0]
    Bound CDVD: cdvdGigaherz.dll [cdvdGigaherz 20180928023358 0.11.0]
(GameDB) 9768 games on record (loaded in 180ms)
    Bound  USB: USBnull.dll [USBnull Driver 20180928023358 0.7.0]
    Bound   FW: FWnull.dll [FWnull Driver 20180928023358 0.7.0]
    Bound DEV9: DEV9ghzdrk.dll [GiGaHeRz's DEV9 Driver 0.4.0]
Plugins loaded successfully.

HLE Notice: ELF does not have a path.

Initializing plugins...
    Init GS
    Init PAD
    Init SPU2
    Init CDVD
    Init USB
    Init FW
    Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
    Opening GS
    Opening PAD
    Opening SPU2
Current Renderer: Direct3D 11 (Hardware renderer)
    Opening CDVD
isoFile open ok: C:\Users\Jorge\Desktop\PS2\SmackDown! Here Comes the Pain\Smackdown - Here Comes The Pain\smk-hctp\smk-hctp.iso
    Image type  = DVD
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (2211360 sectors)
    Opening USB
    Opening FW
    Opening DEV9
Failed to GetNetAdapter()
McdSlot 0 [File]: C:\Users\Jorge\Desktop\PS2\pcsx2-v1.5.0-dev-2571-ge90c87a8e-windows-x86\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\Jorge\Desktop\PS2\pcsx2-v1.5.0-dev-2571-ge90c87a8e-windows-x86\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
GSdx Lookup CRC:0
GSdx Lookup CRC:0
    Bios Found: USA     v02.00(14/06/2004)  Console
    BIOS rom1 module not found, skipping...
    BIOS rom2 module not found, skipping...
    BIOS erom module not found, skipping...
# Initialize memory (rev:3.70, ctm:196Mhz, cpuclk:147Mhz detected)

PlayStation 2 ======== Hard reset boot
 ROMGEN=2004-0614, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
 <20040614-100909,ROMconf,PS20200AC20040614.bin:11696>
# Total accessable memory size: 32 MB (B:2:8:0) (370:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb  6 2003 08:38:48
  CPUID=2e20, BoardID=0, ROMGEN=2004-0614, 32M

Patches: No CRC found, using 00000000 instead.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_520.36;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
found 24480 symbols
ELF (cdrom0:\SLES_520.36;1) Game CRC = 0xF418F2EC, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_520.36;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLES_520.36;1 secname all
loadelf version 3.30
LilyPad: Warning! No controls are bound to a currently attached device!
Please attach a controller that has been setup for use with LilyPad or go to the Plugin settings and setup new controls.
Input ELF format filename = cdrom0:¥SLES_520.36;1
0 00100000 00389580 .........................................................
Loaded, cdrom0:¥SLES_520.36;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Elf entry point @ 0x00100008 about to get recompiled. Load patches first.
GSdx Lookup CRC:F418F2EC
GSdx Lookup CRC:F418F2EC
Welcome to CodeWarrior for PS2
Disk Type is DVD

Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
Disk Type is DVD
loadbuffer: addrres 45d00 args 0 arg
loadbuffer: id 25, ret 0
loadbuffer: addrres 48900 args 0 arg
loadbuffer: id 26, ret 0
loadbuffer: addrres 4d600 args 0 arg
loadbuffer: id 27, ret 0
loadbuffer: addrres 61d00 args 0 arg
loadbuffer: id 28, ret 2
loadbuffer: addrres 48900 args 0 arg
loadbuffer: id 29, ret 2
loadbuffer: addrres 50e00 args 0 arg
loadbuffer: id 30, ret 0
loadbuffer: addrres 48900 args 0 arg
SDR driver version 4.0.1 (C) SCEI
 Exit rsd_main
loadbuffer: id 31, ret 0
loadbuffer: addrres 67700 args 0 arg
loadbuffer: id 32, ret 0
loadbuffer: addrres 52900 args 0 arg
loadbuffer: id 33, ret 0
loadbuffer: addrres 46600 args 0 arg
loadbuffer: id 34, ret 0
loadbuffer: addrres 48900 args 0 arg
loadbuffer: id 35, ret 0
loadbuffer: addrres 54600 args 0 arg
loadbuffer: id 36, ret 0
loadbuffer: addrres 54600 args 24 arg maxtrack=16
loadbuffer: id 37, ret 0
loadbuffer: addrres 54600 args 24 arg maxtrack=16
loadbuffer: id 38, ret 0
loadbuffer: addrres bfa00 args 22 arg maxtrack=3
loadbuffer: id 39, ret 0
loadbuffer: addrres 76e00 args 22 arg maxtrack=8
loadbuffer: id 40, ret 0
loadbuffer: addrres c0e00 args 0 arg maxtrack=8
loadbuffer: id 41, ret 0
loadbuffer: addrres c8800 args 0 arg maxtrack=8
loadbuffer: id 42, ret 0
loadbuffer: addrres cf000 args 0 arg maxtrack=8



@@@@ CMPILE DATE Sep 13 2003 TIME 23:39:03 @@@@
IOP memory  Free 0x100f00(max:0x0f9a00)/0x200000
loadbuffer: id 43, ret 0
loadbuffer: addrres eda00 args 105 arg sdinit=0
CRI ADX Driver Ver.8.94(Sep 14 2003 00:12:01)
CRI ADX Driver : sceSdInit Call = 0
CRI ADX Driver : Main Thread Priority = 47
CRI ADX Driver : PSM Thread Priority  = 47
CRI ADX Driver : DTX Thread Priority  = 48
CRI ADX Driver : SPU CORE Number = 0
loadbuffer: id 44, ret 0
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
libpad: pad port is already open [0][0]
libpad: pad port is already open [0][1]
libpad: pad port is already open [0][2]
libpad: pad port is already open [0][3]
libpad: pad port is already open [1][0]
libpad: pad port is already open [1][1]
libpad: pad port is already open [1][2]
libpad: pad port is already open [1][3]
Suspending single plugin: GS
    Saving GS
    Closing GS
Recovering single plugin: GS
    Opening GS
Current Renderer: Direct3D 11 (Hardware renderer)
GSdx Lookup CRC:F418F2EC
GSdx Lookup CRC:F418F2EC
    Loading GS
DVCI: "BGM¥BGM000.AFS" found.
DVCI: "BGM¥BGM001.AFS" found.
DVCI: "BGM¥BGM002.AFS" found.
DVCI: "BGM¥BGM003.AFS" found.
DVCI: "BGM¥BGM004.AFS" found.
DVCI: "BGM¥BGM999.AFS" Not found.
DVCI: "BGM¥CHEER.AFS" found.
DVCI: "BGM¥BG_ENV.AFS" found.
DVCI: "MOVIE¥PMV000.AFS" found.
DVCI: "MOVIE¥PMV001.AFS" found.
DVCI: "MOVIE¥PMV002.AFS" found.
DVCI: "MOVIE¥PMV003.AFS" found.
DVCI: "MOVIE¥PMV999.AFS" Not found.
DVCI: "MOVIE¥LOGOS_P.AFS" found.
DVCI: "MOVIE¥LOGOS_S.AFS" Not found.
DVCI: "ED0¥ED02.PAC" found.
DVCI: "ED0¥ED03.PAC" found.
DVCI: "ED0¥ED04.PAC" found.
DVCI: "ED0¥ED05.PAC" found.
DVCI: "ED0¥ED06.PAC" found.
DVCI: "ED0¥ED07.PAC" found.
DVCI: "ED0¥ED08.PAC" found.
DVCI: "ED0¥ED09.PAC" found.
DVCI: "ED1¥ED10.PAC" found.
DVCI: "ED1¥ED11.PAC" found.
DVCI: "ED1¥ED12.PAC" found.
DVCI: "ED1¥ED13.PAC" found.
DVCI: "ED1¥ED14.PAC" found.
DVCI: "ED1¥ED15.PAC" found.
DVCI: "ED1¥ED16.PAC" found.
DVCI: "ED1¥ED17.PAC" found.
DVCI: "ED1¥ED18.PAC" found.
DVCI: "ED1¥ED19.PAC" found.
DVCI: "ED2¥ED20.PAC" found.
DVCI: "ED2¥ED21.PAC" found.
DVCI: "ED2¥ED22.PAC" found.
DVCI: "ED2¥ED23.PAC" found.
DVCI: "ED2¥ED24.PAC" found.
DVCI: "ED2¥ED25.PAC" found.
DVCI: "ED2¥ED26.PAC" found.
DVCI: "ED2¥ED27.PAC" found.
DVCI: "ED2¥ED28.PAC" found.
DVCI: "ED2¥ED29.PAC" found.
DVCI: "ED3¥ED30.PAC" found.
DVCI: "ED3¥ED31.PAC" found.
DVCI: "ED3¥ED32.PAC" found.
DVCI: "ED3¥ED33.PAC" found.
DVCI: "ED3¥ED34.PAC" found.
DVCI: "ED3¥ED35.PAC" found.
DVCI: "ED3¥ED36.PAC" found.
DVCI: "ED3¥ED37.PAC" found.
DVCI: "ED3¥ED38.PAC" found.
DVCI: "ED3¥ED39.PAC" found.
DVCI: "ED4¥ED40.PAC" found.
DVCI: "ED4¥ED41.PAC" found.
DVCI: "ED4¥ED42.PAC" found.
DVCI: "ED4¥ED43.PAC" found.
DVCI: "ED4¥ED44.PAC" found.
DVCI: "ED4¥ED45.PAC" found.
DVCI: "ED4¥ED46.PAC" found.
DVCI: "ED4¥ED47.PAC" found.
DVCI: "ED4¥ED48.PAC" found.
DVCI: "ED4¥ED49.PAC" found.
DVCI: "ED5¥ED50.PAC" found.
DVCI: "ED5¥ED51.PAC" found.
DVCI: "ED5¥ED52.PAC" found.
DVCI: "ED5¥ED53.PAC" found.
DVCI: "ED5¥ED54.PAC" found.
DVCI: "ED5¥ED55.PAC" found.
DVCI: "ED5¥ED56.PAC" found.
DVCI: "PAC¥BG.PAC" found.
DVCI: "PAC¥CA.PAC" found.
DVCI: "PAC¥CH.PAC" found.
DVCI: "PAC¥CH2.PAC" found.
DVCI: "PAC¥EDIT.PAC" found.
DVCI: "PAC¥ENTR2D.PAC" found.
DVCI: "PAC¥EVT.PAC" found.
DVCI: "PAC¥EVTDORA.PAC" found.
DVCI: "PAC¥EVTENT.PAC" found.
DVCI: "PAC¥EVTTKME.PAC" found.
DVCI: "PAC¥GAME2D.PAC" found.
DVCI: "PAC¥GM.PAC" found.
DVCI: "PAC¥HALO.PAC" found.
DVCI: "PAC¥M.PAC" found.
DVCI: "PAC¥MENU.PAC" found.
DVCI: "PAC¥MISC.PAC" found.
DVCI: "PAC¥MOVES.PAC" found.
DVCI: "PAC¥MOVIE.PAC" found.
DVCI: "PAC¥SOUND.PAC" found.
DVCI: "PAC¥STABLE.PAC" found.
DVCI: Total 87 files.
DVCI: Warning, Can't load all cache file.
PS2RNA: sceSifAllocIopHeap(266304) ret=0x0010de00
PS2RNA: sceSifAllocIopHeap(2256) ret=0x000c2f00
PS2RNA: sceSifAllocIopHeap(16448) ret=0x000cf000
SDR callback thread created
se load bank[1]
se load & trans end bank[1]






[/code]
It's odd. In the log, when it says that I switched to D3D11 I was actually trying to switch to OpenGL on the settings.
Reply
#9
i'd erase the inis end reconfigure from scratch
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#10
(09-30-2018, 10:01 PM)jesalvein Wrote: i'd erase the inis end reconfigure from scratch

How should I proceed in this case? Just deleting the "inis" folder? Should I do something after that or should I just run the emulator normally?
Reply




Users browsing this thread: 1 Guest(s)