Some general questions about PCSX2 and Soul Calibur 3
Hello Smile

nice website Smile

... sooo, after more or less succesfully being able to use the nintendo64 emulators, I gave this PS2 emulator a try.

After lots of trying out and reading, I managed to run SC3 (.iso) kinda properly with the following combinations of plugins:
[Image: 010411223022_pcsx2.JPG]

and I've encountered the following problems (haven't tried other games yet so this is only related to SC3):

- There are some vertical black/white lines making it much harder to enjoy the visuals of the game. Can I get rid of them?

- On one single level (the map with rain and a ship [Maxi's level]), the game starts to stutter extremely, both graphics and sounds. Weirdly, when I make a 180° turn on the map and watch the ship, the game becomes completely fluid again.

- When I play "tales of souls" mode and go out of the game to buy something from the shop for instance, and then re-enter that mode with the same Character, I have to start all over again. Is that normal?
- I thought I could avoid that by simply using savestates (at least so I can decide to turn the game off even if i'm in the middle of a play-through). They seemed to work fine, but as soon as I fully quit PCSX2 and restart it, all the savestates are deleted. Are those savestates only temporary or is that a bug?

- Is this a good set of plugins and are they up-to-date? (Couldnt get the other Pad plugins to run in the 0.9.7. version - lillypad worked fine in 0.9.6)

Thanks in advance for any help! Smile


Sponsored links

1) Use a custom reoslution like 1270x1270, 1200x1200, 1020x1020 to get rid of the lines.
2) Try lowering resolution or enabling/disabling "Allow 8-bit textures" in GSdx for the slowdown, would help if you tell us the EE/GS% numbers in the game window when you get slowdowns.
3) Yes it's normal, it's only like 10 fights in the story mode if you leave you should start from the beginning again.
4) Sounds like a permissions problem, check in the "sstates" folder to see if the the files are .tmp files.
5) Except for the pad plugin they're the default plugins in the latest beta, so yeah they're fine.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Ah very cool. with 1080x1080 the lines are gone Smile. And the lower resolution is no loss at all since it's a rather old game anyways Smile.

Activated the allow 8 bits option - I hope this is gonna fix it. If the problem still appears I will post again.

I checked the sstates folder, and found 3 files. I loaded slot 2 and it loaded the game. So I dunno what went wrong - yesterday I tried to load slot 2 and got the message that slot 2 would be empty. Anyways, it seems to work fine now Smile.

Thanks for your quick support!
Oh and another thing: In levels with "special effects" the characters start to look like this:

Is there an option to fix that? Smile (I mean that blurry shimmer around them)
The offset hack might help that, it looks like it's suppose to be over the character, but isnt ;p
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
(04-02-2011, 04:37 PM)refraction Wrote: The offset hack might help that, it looks like it's suppose to be over the character, but isnt ;p

Okay I've made some research and according to what I've found HERE, that hack should fix exactly my problem. But it doesn't do anything.This is what I entered in the gsdx.ini:


But none of these have an effect. At least not when I use a savestate to land in that level again.

btw the next level looks like THIS. I dunno if it's the same issue or something else. Just everything looks blurry. Also the sound quality drops and some stutters appear (and disabling the speedhacks causes an ugly slow-down). I'm happy I encouter these bugs only every few levels, so it's no biggie - still it'd be nice to have that fixed aswell.

Any other ideas? Smile

A little update:
I ended up randomly enabling and disabling options. I disabled Filters and set the upscale_multiplier from 1 to 0. That had this effect:

Just ignore the missing filters. The problem I encountered got worse. So I quit and tried upscale_multiplier=2. Which solved my problem (I think?). Those shining effects are now where they should be (I guess?). The problem: The vertical lines are back! Rolleyes. Take a look:

Also I've recognized some tiny slow-downs and stuttering. Is upscale_multiplier=2 taking more hardware? (Sorry I can't think of a better expression right now xD). Might aswell be the msaa I activated. And how do I get rid of the returned vertical lines?

And another update:
Apparently Offset DOES have an effect. When using a higher value of upscale, the "ghost" of the actual character is moving into the wrong direction. Turning the Offset hack on does nothing with upscale 1, but almost synchronizes the "ghost" with the actual character. Upscale 3 looks even better and updscale 4 is too far away again... So I'd need something like 3.5 Updscale, which is not possible. Besides I have a permanent slow-down then so that's not an option.

I'd be happy if I could use upscale 2 without the lines. Is that possible somehow? Smile
Yeah, unfortunately the "offset hack" only works in scaling resolutions and not in custom ones, and using scale resolutions (2x/3x/etc) will give the thin lines. For now for this game it's either play in native resolution (no ghosting or lines like that) or pick your poison (ghosting or thin lines).

Random note: In earlier revisions of GSdx you could use yet another option in the .ini (pixoff_x) but that one had different problems so anyway, for now just the other options Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
I understand. I'll go with the little ghosts every few levels then Tongue. Thanks for your help Smile.
Okay there is something else I would like to know Tongue.

When having used savestates, I can see the silhouettes of.. I'm not sure - maybe the beginning of the level or the picture I saw before pressing F3. Anyways, it looks like this then:

I can fix it by pausing the emulation (esc) and resume it in the menu. But I really use the savestates A LOT Tongue. And it is getting kinda annoying. So:

- Can I fix the bug completely?
- Is there a bind for resume or can I make one ('cos only having to press 1 key two times would be just as good as an actual fix)?
- Is there something like vid_restart (any command to just restart the graphics plugin or something similar. Ofcourse it should be possible to bind it on a key, or it wouldn't be better then the method I am using right now).
Savestates are buggy, it's just the nature of the beast unfortunately... especially with something as complex as the PS2.
[Image: 2748844.png]

Users browsing this thread: 1 Guest(s)