Thread Rating:
  • 54 Vote(s) - 4.76 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XInput Wrapper for DS3 and Play.com USB Dual DS2 Controller
Getting this when attempting to pair a DS4 over Bluetooth on Windows 10 (using your build Nefarius)

http://imgkk.com/i/gty7.png

(The error that is cropped off is line 183)

Pairing a DS3 over bluetooth seems to be working fine and DS4 works over USB, but no joy with DS4 over bluetooth
Reply

Sponsored links

(08-05-2015, 09:46 PM)Darkimmortal Wrote: Getting this when attempting to pair a DS4 over Bluetooth on Windows 10 (using your build Nefarius)

http://imgkk.com/i/gty7.png

(The error that is cropped off is line 183)

Pairing a DS3 over bluetooth seems to be working fine and DS4 works over USB, but no joy with DS4 over bluetooth

No need for screenshots  Cool There should be a file called ScpDsxServer.log.xml in the directory, please attach it here so I can review it.
Reply
(08-05-2015, 09:49 PM)Nefarius Wrote: No need for screenshots  Cool There should be a file called ScpDsxServer.log.xml in the directory, please attach it here so I can review it.


Attached Files
.xml   ScpDsxServer.log.xml (Size: 101,96 KB / Downloads: 368)
Reply
I've been usimg this program on Windows 8.1 and it has worked flawlessly. After installing Windows 10, it won't work anymore. I don't know why. I've tried reinstalling it but it still doesn't help. Do any of you guys know how to fix this for Windows 10? I'm using PS3 controller.

PLEASE HELP! Sad
Reply
@Nefarius

bluetooh dont work.


Attached Files
.xml   ScpDsxServer.log.xml (Size: 26,67 KB / Downloads: 479)
Reply
(08-05-2015, 07:22 PM)Nefarius Wrote: Please check if a service named SCP DS3 Service is present in the services console. If not (and you are running my build; version 1.3.x), open an elevated command prompt, navigate to your Scp-folder like so:

Code:
cd "C:\Program Files\Scarlet.Crush Productions"

and execute the following command:

Code:
ScpService.exe --install

After this, the service should be back in the services console.
The Service is there, just the dependency for it (The Spc Virtual Bus) isnt there so it wont start anymore. Although, Im not using your build, so ill see if i can uninstall the old build and install yours. Im still using 1.2.x. Hopefully installing a new build will allow the virtual bus to be installed properly because even when i uninstall and install the current build the dependency does not return.

EDIT: I installed the most recent build 1.3.x and the service still would not start. Also tried installing the service via elevated command prompt and that did not work either. I posted my install log of 1.3.x also.


Attached Files
.xml   ScpDsxInstaller.log.xml (Size: 48,03 KB / Downloads: 263)
Reply
I have a problem: I had this working just fine with a DS3, but after getting a DS4 I uninstalled and moved to DS4Windows. After running into some unexpected yet irrelevant issues there, I've tried to come back to this; but I can no longer pair any gamepads to my PC with this original program - not even the original DS3 I was using.

I uninstalled drivers as correctly as I could using the driver installers for both programs, and I've restarted numerous times to make sure the service had started, but to no avail.

I can reinstall and use DS4Windows as well as ever.

Anyone know what's up?

Edit: Had another try and somehow it decided to recognise my ds3; but it won't read inputs, and it isn't seeing my ds4 (connected via cable and is registering dx inputs). Obviously, I would like to be able to use my controllers so I'm still after help if I can get it.
Reply
Built the latest source from git as of this post and getting the same issue with DS4 bluetooth
Reply
(08-05-2015, 07:25 PM)hellbringer616 Wrote: So i'm having an issue with my new dongle with the new version of the driver.
The driver is installed over the proper dongle, showing up as BTH DS3 in device config. however no matter what i'm not getting a bluetooth connection.
These are store bought official DS3 controllers i am using if it matters

Any steps i can take? controller functions fine with USB

EDIT: it's a cirago BTA6310 with VID USB\VID_0A12&PID_0001
if it helps

EDIT2:
Looking at the SCP Server program i am getting the following:
%PathToSCPServer.exe%
%PathToSCPControl.dll%
%OSInformation%
-- Bus Open:    Offset 0
-- Bus Open:    Path \\?\ROOT#SYSTEM#0001#{stringvalue} (if the value is important i can type it out, but it's long)
LastError = 5
##Mapper.Initialize() - Profiles [5] Active [Default]  Mappings [0]
LastError = 5
Just tried with the Scarlett.Crush version of the driver (from the first page) and same issue, it installs but does not work with bluetooth. Is my device just incompatible?
Intel Core i7-8700k @5ghz
G.Skill 16GB DDR4 @3600mhz
GeForce GTX 1080 8GB
Windows 10 x64
Reply
(08-05-2015, 05:26 PM)Luckyjacks Wrote: sorry was posting a wrong log Wacko anyway,  still wander if this says, that it should actually work??
Reply




Users browsing this thread: 13 Guest(s)