Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GT4.... help a NOOB!! please
#21
(03-07-2009, 09:19 PM)cyber Wrote: @Wohlrajh
Thanks for the reply.
Well I could play the events all over again, it's still fun I guess.
I can try with 0.9.6, if you say there is a difference in memcard management. Actually I do remember Krakatos updating in the svn snaphot thread, and there were lot's of svn's which had changes to memcard handling.
If you want or have the time please post a memcard anyways.

Check your PMs, I've sent you a link to dl my memcard Wink Enjoy
Core 2 Quad Q9550 @ 3.7Ghz - Geforce GTX 280 1Go OCed @ 640/1400/1200 Mhz - 4Go RAM Corsair Dominator PC2-8500 - Sound Blaster X-Fi Fatal1ty Pro Series - Windows Vista Ultimate x64

Sponsored links

#22
So, I've tried everything in this thread, and still its a no go. I get stuck on the intro. It does the legal stuff and goes black and won't move forward. Config is as follows:

PCSX2 0.9.6

GSdx 890 (MSVC 15.00 SSSE3) 0.1.14
ZeroSPU2 r514-Dev 0.4.6
Lilypad 0.9.9
Linuzappz ISO CDVD 0.7.0

Computer specs are as follows:
CPU: Intel e6600 (dual core)
GPU: GeForce 8800gts
4gb ram
Vista business x64

The iso came from my DVD. I've tried playing directly off of the DVD, and I used MagicISO to make an ISO out of the DVD. Both ways yield the same result.

As far as speed hacks, I have only the default one active (Default Cycle Rate). As far as I can tell these is no way to turn this off?

The only thing I can think is this is a 64 bit problem, but that wouldn't make a whole lot of sense, since generally if its a 64 bit problem I will have issues long before I even get to trying to play the game itself. I suppose the easy fix would be for someone to post a save state just past the intro for people like me who can't get past it, but I'd like to find a more permanent solution. If anyone has an extra plugin or something I'm missing / should have, please point me to where I can get it.

Hopefully someone can figure this out. My sister stole my PS2 when I went to college and I've had no way to play this game for the last 3 years. Finally victory seems within my grasp!

Thanks.
#23
I get the following when trying the B license tests.

(EE) Tlb Miss, addr=0x2000000 [store]
(EE) PC: 0x00346d24 Cycle: 0xe25f5de2

And ocasionally while browsing the menues:

8bit write (possible chcr set) to addr 0x1f80190a = 0x0

No speedhacks.
#24
(03-09-2009, 08:10 PM)InfamousBLT Wrote: So, I've tried everything in this thread, and still its a no go. I get stuck on the intro. It does the legal stuff and goes black and won't move forward. Config is as follows:

PCSX2 0.9.6

GSdx 890 (MSVC 15.00 SSSE3) 0.1.14
ZeroSPU2 r514-Dev 0.4.6
Lilypad 0.9.9
Linuzappz ISO CDVD 0.7.0

Computer specs are as follows:
CPU: Intel e6600 (dual core)
GPU: GeForce 8800gts
4gb ram
Vista business x64

The iso came from my DVD. I've tried playing directly off of the DVD, and I used MagicISO to make an ISO out of the DVD. Both ways yield the same result.

As far as speed hacks, I have only the default one active (Default Cycle Rate). As far as I can tell these is no way to turn this off?

The only thing I can think is this is a 64 bit problem, but that wouldn't make a whole lot of sense, since generally if its a 64 bit problem I will have issues long before I even get to trying to play the game itself. I suppose the easy fix would be for someone to post a save state just past the intro for people like me who can't get past it, but I'd like to find a more permanent solution. If anyone has an extra plugin or something I'm missing / should have, please point me to where I can get it.

Hopefully someone can figure this out. My sister stole my PS2 when I went to college and I've had no way to play this game for the last 3 years. Finally victory seems within my grasp!

Thanks.


either make a new pnach file for gt4 and put this in it

gametitle=Gran Turismo 4 NTSC U/C SCUS97328
//skip Videos
patch=1,EE,00100D84,word,24100001

or if you have no clue how to do that, dl my pnach and just make sure the crc is the same from the game you use and the name of the pnach file.


Attached Files
.pnach   77e61c8a.pnach (Size: 95 bytes / Downloads: 10.148)
[Image: 1816969.png]
#25


either make a new pnach file for gt4 and put this in it

gametitle=Gran Turismo 4 NTSC U/C SCUS97328
//skip Videos
patch=1,EE,00100D84,word,24100001

or if you have no clue how to do that, dl my pnach and just make sure the crc is the same from the game you use and the name of the pnach file.
[/quote]

Well snap. That was a success. Thanks so much. I actually had that pnach already, but apparently I had forgotten to enable patches. And now I'm in. You are my hero. <3
#26
It seems that there is a problem with the intro since some revisions, I didn't notice it because the game worked for me since more than a month now, and I directly came to the options to skip the opening movie because I knew it was unstable.

The idea of the skipping intro patch is good, it should help the people being stuck on the intro Wink

Now if some guys succeeded in playing this game I would like to know two things (for NTSC version):

- Are you using DX10 ? Because for me it crashes the emu each time I try to launch a race.. With DX9 it's fine but with some graphical bugs. If anyone playing with DX10 could link his emu config, or knows a trick to make it work that would be great ! Tongue

- I can play the game at 60 FPS the major part of the time BUT I have big slowdowns (-20 FPS Sad ) each time there is a big light source on screen(e.g when we see the sunshine, or in races by night, etc) If anyone succeded in getting rid of these ones, old GSdx version or whatever I would be very happy Tongue I tried a lot of GSdx versions but it remains the same :'(

Thanks
Core 2 Quad Q9550 @ 3.7Ghz - Geforce GTX 280 1Go OCed @ 640/1400/1200 Mhz - 4Go RAM Corsair Dominator PC2-8500 - Sound Blaster X-Fi Fatal1ty Pro Series - Windows Vista Ultimate x64
#27
in order for me to do a race i had to go to options and video or screen and change the output to 480p.
not sure if that will work for you, and remember that is 'high-def' so not sure if that will work for anyone using older CRT monitors
[Image: 1816969.png]
#28
(03-10-2009, 08:46 PM)anorexic Wrote: in order for me to do a race i had to go to options and video or screen and change the output to 480p.
not sure if that will work for you, and remember that is 'high-def' so not sure if that will work for anyone using older CRT monitors

You mean you're playing with DX10 ? Because I'm already playing with 480p mode but it crashes if I try with DX10, with DX9 it's fine. I've got a LCD and 480p is working fine but not with DX10, I have Vista 64 and other games work fine with it, just don't know why it refuses working with GT4 ^^

Can you post a screen with your emu config that I can compare with mine, or write them here please ? Tongue
There's perhaps a thing that I'm missing xD
Core 2 Quad Q9550 @ 3.7Ghz - Geforce GTX 280 1Go OCed @ 640/1400/1200 Mhz - 4Go RAM Corsair Dominator PC2-8500 - Sound Blaster X-Fi Fatal1ty Pro Series - Windows Vista Ultimate x64
#29
Hi everyone! Im new in all this but i got pcsx2 and GT4 NTSC version and simply can't pass intro... I downloaded that pnatch file and copied in patch dir but seems its not working (patches enabled). Did i missed something because in misc there is few more patch options and i don't know how to use 'em. Also my pscx2 is configured same as u guys told in this post. Thanx in advance.
#30
Try pressing X or Start.




Users browsing this thread: 1 Guest(s)