Thread Rating:
  • 54 Vote(s) - 4.76 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XInput Wrapper for DS3 and Play.com USB Dual DS2 Controller
(12-29-2013, 02:40 PM)dhstsw Wrote: Ok, solved.

Instead of stopping and start again the service, i did it this way:

-USB Disconnected;
-Disable SSP on SCP Monitor config;
-DIDN'T close it;
-Restart the service (not stop and start, *restart*) while SCPMon is on;
-Then, host adress gets populated! (yeah!).
-Connected USB;
-Disconnected USB;
-DS3 gets connected on BT (yeaaaah!) Smile

Thanks Scarlett for the great SCP Smile

Thanks dude! Worked fine for me too.

Anyone know how to manually pair the DS3?
Reply

Sponsored links

(12-29-2013, 02:32 AM)gothvan Wrote: Hello, I've read some post and I'm not sure to understand my problem. My knowledge in this kind of stuff is pretty basic, so I'll hope you'll be able to help.

My ds3 works perfectly when i'm usb connected. However, in monitor, Host address is disconnected. I tried to find my hardware id in Device manager > bluetooth radios > Generic Bluetooth adapter (then details and hardware id). The hardware id is USB\VID_0B05&PID_17D0


should I do something specific? Thank you!

Update. I backtracked more post and installed tools and with zadig I now have a Host adress, my bluetooth is in device manager under Universal serial devices. However, in scpmonitor, even with the host adress, when I unplug the ds3 I see that the Pad 1 is reserved and nothing more happen.

General bluetooth device hardware id USB\VID_0B05&PID_17D0 and USB\VID_0B05&PID_17D0&REV_0001

What do?
Reply
Hi!

I've experienced diffrent issue. After pairing DS3 with PC, everything looks corrects besides the triggers. In Control Panel -> Set up USB game controllers, every key work but not triggers. I have been trying to manually calibrate the gamepad (triggers works during calibration) with no effect.

OS I am using - Windows 8 x64. I can provide more debug data if you need.

Thanks,
Łukasz
Reply
@Scarlet.Crush
Tried disabling SSP to no avail. Looks like it's trying to connect, but never becomes usable over BT. I have a host address, as well as a reserved address showing up in the monitor, it just seems that the dongle isn't completing the connection.

I got it to work a week before the DS4 update you made, but only intermittently due to my dongle not being in the list and having driver signing issues on win 8.1 64-bit. I now have used the signing workaround, but now have this new problem. Log attached.


Attached Files
.zip   ScpService .zip (Size: 1,2 KB / Downloads: 123)
Reply
(12-29-2013, 05:54 PM)gothvan Wrote: Update. I backtracked more post and installed tools and with zadig I now have a Host adress, my bluetooth is in device manager under Universal serial devices. However, in scpmonitor, even with the host adress, when I unplug the ds3 I see that the Pad 1 is reserved and nothing more happen.

General bluetooth device hardware id USB\VID_0B05&PID_17D0 and USB\VID_0B05&PID_17D0&REV_0001

What do?

Update 2. After uninstalling and reinstalling I'm not saying any bluetooth installation even if it was checked, forced etc. I'M GOING CRAZY

-- Install Summary --
SCP DS3 Service
Bus Device
Bus Driver
DS3 USB Driver
Reply
Is there ANY way to get this to work with Dark Souls? I really don't want to go back to MotionJoy...
|| Core i7 8700K @ 5.0GHZ || Gigabyte AUROS 1080 Ti 11GB @ 2050MHZ/12GHZ Memory || 32GB DDR4 @ 3000MHZ || 1TB Samsung Evo 850 SSD + 128GB 830 SSD || 4TB HDD + 1TB HDD || Windows 10 64-bit Professional || EVGA G3 850w PSU || MB: Z370 AORUS Gaming 5 ||
Reply
@[Suda Snickers]: follow the New Install procedure in Post #1, when you run ScpDriver uncheck "Bluetooth Driver".

@gothvan: can you do the following -

1. Shutdown your PC.
2. Disconnect your controller from USB.
3. Start up your PC.
4. When your Desktop has popped up, plug in your controller to USB.
5. Wait 30 seconds.
6. Disconnect your Controller from USB.
7. Zip up your ScpService.log and ScpDriver.log and post as an attachment.

@ramonoakz: do you want to manually pair your DS3 to an external device?

@svider: there is a bug in the display tab of the Windows 8/8.1 Game Controllers app (DInput). It does not properly display the Z Axis. There is nothing wrong with your Pad, it will behave properly in-game.

Run ScpUser.exe to see XInput for your Controller.

@Ashnal: from the log it looks like your DS3 is performing an HCI connection, but is not then performing an L2CAP connection.

Can you try a Pinhole Reset of your DS3.

@Mkilbride: Dark Souls should detect your DS3 as an X360 Pad and work without any configuration.

A few games will not recognise an attached X360 Pad if any other controller is connected. [Assassin's Creed 3 being one]. Dark Souls Steam Forum

Forum also mentions an incompatibility with DSMfix.
Reply
(12-29-2013, 10:07 PM)Scarlet.Crush Wrote: @gothvan: can you do the following -

1. Shutdown your PC.
2. Disconnect your controller from USB.
3. Start up your PC.
4. When your Desktop has popped up, plug in your controller to USB.
5. Wait 30 seconds.
6. Disconnect your Controller from USB.
7. Zip up your ScpService.log and ScpDriver.log and post as an attachment.

Here it is. I hope I did it allright. Thank you very much for your time. It is appreciated.


Attached Files
.rar   gothvan.rar (Size: 1,98 KB / Downloads: 90)
Reply
It's a PS3 Controller. I have it installed and other games recognize it, without problem. I loved this since I found it and got rid of that ***** MotionJoy...but it actually works with MotionJoy...in Dark Souls that is...so...I don't know what to do.

I don't have DSmfix installed. As for other controllers...my Logitech G13? Isn't really a controller...but...
|| Core i7 8700K @ 5.0GHZ || Gigabyte AUROS 1080 Ti 11GB @ 2050MHZ/12GHZ Memory || 32GB DDR4 @ 3000MHZ || 1TB Samsung Evo 850 SSD + 128GB 830 SSD || 4TB HDD + 1TB HDD || Windows 10 64-bit Professional || EVGA G3 850w PSU || MB: Z370 AORUS Gaming 5 ||
Reply
Bug 
@Scarlet .Crush:
Thanx for the awssome software and all the support, i have been browsing a lot arround and i admit it is amazeing how responsive and active the forum is Blink ..
  • >
    I have a problem Sad that i cant seem to figure on my own and im not sure if i can get some help... basically, i cant get the Bluetooth to work.

  • >
    I started with motionjoy and then passed to better ds3 finally finding these option to be of my likeing, yet i cant use my bluetooth with my ds3 (dungle or integrated)...

  • >
    I followed every step in the post (360 driver, .NetFW 4.0, C++runtime...)...

  • >
    I tryed newer drivers, i bought an iogear GBU421 (since it was listed and someone said it was flawless), i attempted to install the drivers manually (better ds3), and whatever i do, when i disconect my usb from the controller, its off.. nothing happends... (I did restored the whole system before the date of motionjoy so Drivers were the newer from the broadcomm maker)

  • >
    I checked the service log but i belive its not reciveing bluetooth information, plus im not sure i know ow to make it work...

My laptop is a dell studio 1555 with win7 64x, (4g ram, core2 duo 2.53) Videocard is ATI Mobility Radeon HD 4570 256mb

What else can i try?
Am i missing something?
I thought i had done everything...

One last thing; i have noticed that whi i turn on a second BT dungle (if i instal iogear and integrated BT is on), the second one i activate displays an error "error 10: device cannot start", i ignored this since the driver doesnt reconize it as BT animore after installing, and there is no error after installing anyway; plus i simply turn integrated bluetooth off and then i install BT dungle then driver, so i manage to avoid it from hapening...

Thankyou!! Smile
Reply




Users browsing this thread: 5 Guest(s)