Thread Rating:
  • 89 Vote(s) - 4.45 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GSdx
Does development of plugins goes independently of emulator? If anyone maybe would send in my inbox link of alredy compiled plugins ;D
Reply

Sponsored links

Quoting myself from another thread:

(06-30-2010, 03:50 AM)avih Wrote: ...

So, with GSDX 2693, 2817 and 2897 (SSE4.1 build when possible, w32pthreads[.v3].dll required at exe dir) AA is not crashing and is effective: tried 2, 4 and 8 with native resolution. AAx8 had a heavy FPS penalty (50% speed drop) but it's working.

On GSDX 3068 and later revisions (tried also 3183 and 3296) it crashes immediately for me. Tested with PCSX2 0.97.3113 and also with a later 0.97.3184 - same results. With 3113 I also tested the SSE2 build of GSDX 3068 - also immediate crash.

I don't have GSDX builds between 2897 and 3068.

I use DX9, fully updated to latest revision. Rest of the system is stock as appears on my sig.

emuLog.txt doesn't contain anything meaningful. The last related (IMO) message is that all the plugins were initialized successfully. It doesn't seem related to any game since it also happens when just booting the Bios. To me it seems that it crashes as soon as GSDX is trying to update the screen for the 1st time when in AA>0.

...

I've since narrowed it down to between 2966 (OK) and 3003 (crash). Some more info: using latest NVidia drivers - 257.21 WHQL.

I also looked at the revisions logs, and it seems that 3002 had many DX9 modifications, and it's also already reported that it breaks HW AA in DX9 - first comment from May 22, 2010 - http://code.google.com/p/pcsx2/source/detail?r=3002 .

EDIT: GSdx 3000 doesn't crash. res 2x native and AA x2 works beautifully with minimal FPS drop... so it's most probably indeed 3002...

FWIW, since the log states modifications to the z-buffer, I also tested with unchecked Logarithmic Z, and it also crashes immediately.

Well, just reporting it's still broken with latest builds.
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
Are plugins on google source the latest and all we need to do is compile it all?
Reply
yes, though you probably will not get support for using them
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
That way you can probably take part in PCSX2 development by sending bug/regression reports... Smile
Reply
we know of issues of directx 9 cards being detected as directx 11 causing them to crash, you could try manually setting it to DX9, but i dont know if that will help..
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
(07-01-2010, 02:19 PM)refraction Wrote: we know of issues of directx 9 cards being detected as directx 11 causing them to crash, you could try manually setting it to DX9, but i dont know if that will help..

I only see Direct3D9 (Hardware/software/Null) and Null (Software/Null) on GSdx config panel drop-down. I'm guessing it's detected properly as DX9? How does it look like when DX10/11 are also detected? more items on the drop-down list?

It's obvious something got broken on r3002, I'm guessing it's just some broken init sequence, but it's probably ugly to find because of the 'code shuffling' in this build, still, it would be nice to have AA back...


BTW is AA broken on DX9 for everyone or just for some? Current posts suggest that everyone who insisted AA works, has been using DX10/11...
[i7-3630qm/gt650m-2G/Win-7] [i7-4500u/R.HD8850m/Win-8.1] [2010-MBA/OSX-10.9.x]. Scroll smoothly with SmoothWheel for Firefox.
Reply
@ avih

Yeah,AA is broken on dx9 for me too
Reply
Steambot Chronicles runs perfectly in GSdx Hardware Mode until (after the short text intro) you actually get into the game and the character goes "ugh" on the beach. Then there's a bunch of vertical lines on the screen. The game works fine, albeit slow, in Software Mode. At least that part of the game does.

I'm using GSdx r3183 (and have tried it with the versions that came with PCSX2's r3119 release from this website) with PCSX2 r3119 and r3353. I used it with the SSE2, SSE3, SSE41 versions all with default settings, then nothing checked, then in PS2 native resolution. Nothing changes.

my computer:

ATI 4870 1GB with 10.6 Catalyst drivers.
8400 Core 2 Duo @ 3.00
4 gigs ram
Windows XP 32 bit with Service Pack 3


Attached Files Thumbnail(s)
           
Reply
Newest release of GSDX10 plugin, it runs Dragon quest 8 about 50% slower than the eqivalent DX9 GSDX plugin does. The game is also blurry on the DX10 GSDX.

Ati 4850 GPU

Settings...
1024x1024
NO AA
No game fixes or hacks on

3068 DX9 = 62 FPS
3068 DX 10= 45 FPS, also looks blurry

Same fps drop on native aswell in DX10 mode, 9 sees a large increase.

Tried the 2693 GSDX release...AA works in that release. And the DX10 mode on that plugin works correctly. There is a ~6fps gain over DX9 in that plugin [swapping between 9 and 10]. And a ~6 fps gain over the most recent DX9 plugin...So 3068 DX10 GSDS is buggy [with AA and speed on some systems].

So to summarise...
3068 [DX9 and 10] - AA is broken on some peoples systems [not all it seems].
3068 [DX10 only] - Dragon quest 8 is blurry, and has a FPS hit that is not seen in the DX9 release. AA is broken.
2693 - AA works fine in both dx 9 and 10 modes, on all system configs [that I have heard of]. DX10 works correctly in DQ8 and has a FPS increase over 2693 GSDS DX9 and the 3068 DX9/10 release [6fps increase].
Other games probably have issues with the 3068 DX10 release aswell.


I can add more info if needed.
Reply




Users browsing this thread: 2 Guest(s)