Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved: Latest Dev Builds not loading... on WinXP-Pro
#11
For me, this was the commit which was causing pcsx2 to hang upon startup.

If you're able to compile your own build, try reversing the edit from line 62 in that commit. I've tested this on WinXP and Win7, and it's working successfully.

Sponsored links

#12
At least here,the problem is related to GSdx,not pcsx2.
I tried the plugin with pcsx2 1.0.0 and I got the same freeze...it's not really freezing but it's causing huge load on the system that makes it look like it freeze but pcsx2 is actually running at 0.??fps

Edit:And btw after that happens and I kill the pcsx2 process,every video player is behaving almost the same way until I restart the pc
#13
sounds like the issue i got but i'm using windows 8.1.

this is the latest build that works for me;
*snip*
anything higher and it only displays the log window and then hangs.
sometimes says plugins shutdown, but mostly just a blank window.

pcsx2 window doesn't even show up.
#14
No linking to unofficial builds.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#15
sorry, even if the changelog matches the one on build bot? i just assumed emucr just re-post most things off other sites.
#16
No, they compile the builds from source on their own. We have no control over them, how they compile, what conditions they set, etc. So we have no way if knowing their builds are valid. FWIW they usually seem to work, but I know of at least two times I can recall that their build caused issues when the same build on buildbot didn't.

Anyway, I sent a PM to rama and the devs are aware of the situation. I need someone to work with me to confirm if it's really the commit mentioned previously in that thread. I will compile two builds of PCSX2, with all recent commits. One will have the commit in question intact, and one with it reversed. Then we can confirm if that is really the problem. The devs don't see how that commit could break things like this, which is why we need to test.

So anyone who wants to help, please shoot me a PM or post here. (In order to help you need to be one of the ones with this crashing issue. I can't test myself because I don't have the issue)
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#17
Blyss,I don't know what Melchior tried but in my case,when I start a game in DX9HW mode,shortly after that the whole system will freeze(or rather,reacting to command will become extremely slow,like the pc is running at 0.??fps Tongue )

What I did find is this:
v1.2.1-256-g3daff15 - works fine
v1.2.1-257-gd3ebdae - the problem exist

PS.I'm not at home during the day(until 18:00 so I can't try modified builds...here is 1AM now)
The problem is GSDX not pcsx2
#18
I've discovered something new by accident here...

The hanging seems to occur when the visual theme is set to Windows Classic, tested on Windows 7. (and yes I prefer the classic theme.)

Windows XP still seems to hang regardless of the theme choice.

   

--------------

One more thing I noticed : screen resolution.

On Windows XP and Win7 (with the Classic theme), pcsx2 will start without a problem if I used a relatively low resolution like 1024x768 or 1280x720.
But when the screen resolution is something a bit higher like 1440x900 or 1920x1080, it will hang on startup.

Starting at a low screen resolution and then changing to a higher resolution afterwards seems to work once pcsx2 is visible.

Everything seems to work fine if I'm using Windows 7's theme (Basic or Aero, it does not matter)

From a bit more testing, the hangs seem to be happening if the screen resolution's height is greater than 795 pixels.
#19
^ Very nice find!

You are right. I switched my theme to classic on Windows 7. Running at my normal res of 1680x1050. Launch latest build - hang.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#20
(10-25-2014, 06:26 AM)Blyss Sarania Wrote: ^ Very nice find!

You are right. I switched my theme to classic on Windows 7. Running at my normal res of 1680x1050. Launch latest build - hang.

Confirmed. Happens here too. (1920x1200 = Desktop resolution)
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)




Users browsing this thread: 1 Guest(s)