Thread Rating:
  • 16 Vote(s) - 4.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ScpToolkit (XInput Wrapper aka ScpServer Reloaded)
http://www.xup.in/dl,14900876/ScpDsxInstaller.log.xml/, http://www.xup.in/dl,18459120/ScpDsxService.log.xml/ here they are its not a problem that is on the original post. Thanks my little 1337h4x0r.

Sponsored links

My gamepad is more compatible !
nyko core controller has no sixaxis...
but mine, has sixaxis function (tested it with motioninjoy)
Has pressure sensitive for all buttons (excluding start,select,ps,R3 and L3 buttons)
Its MAC address starts with 00:26:5C.
But my host address starts with 00:1A:7D , is this related?

According to ScpControl.ini :

[BthDongle]
; Partial product name of supported bluetooth dongles
SupportedName = -ghic
; Partial host MAC addresses of supported bluetooth dongles
SupportedMac = 00:26:5C
SupportedMac = 00:16:FE:71
SupportedMac = 00:24:5C

[BthDs3]
; Partial product name of supported DS3 controllers connected via Bluetooth
SupportedName = -ghic
; Partial remote MAC addresses of supported DS3 controllers connected via Bluetooth
SupportedMac = 00:26:5C
SupportedMac = 00:24:5C
...
Dear all,
I have trouble getting this to work with my original Sony DS3 controller which worked more or less with the MotionInJoy driver (aside from the occasional blue screen) under Windows 10. I tried to switch to the xinput-wrapper following this:
http://emulation-general.wikia.com/wiki/...structions
and this:
https://github.com/nefarius/ScpServer/bl...ion-how-to
manuals.
However, the controller didn't work anymore afterwards.
When trying to troubleshoot the problem, I realized that (by now?) Windows does not even realize that the controller is connected to the USB port (not even USBView.exe shows it). The USB cable is fine (other components work when connected to it). Installing the Xbox 360 controller drivers (for Windows 7) from:
https://www.microsoft.com/hardware/en-us...or-windows
didn't change anything.
Did I manage to somehow shoot my Windows completely when (un-)installing MiJ and have to reinstall Windows now or is there anything I can do to get the DS3 controller back to be recognized by the system?
(09-21-2015, 08:05 PM)Nefarius Wrote: You only did one half of the service Laugh please also connect the DS3 via Bluetooth at least once Cool To be absolutely honest; I just went into the store and grabbed the first in sight, it's brand name is HAMA.

EDIT: this is the one I got.

If you want more range get one that looks like this with an antenna.
[Image: BBE-BluetoothDongle_1.jpg]
I've been trying to get this to work for hours now without success; can somebody help me diagnose the problem? My install log is as follow
9/21/2015 7:13:07 PM [INFO] - SCP Driver Installer 1.5.5740.18577 [09/21/2015 19:13:07]
9/21/2015 7:13:07 PM [DEBUG] - Preparing to load DIFxAPI
9/21/2015 7:13:07 PM [INFO] - Running as 64-Bit process
9/21/2015 7:13:07 PM [DEBUG] - DIFxAPI path: C:\Users\John\Documents\SCP DS3\bin\DIFxApi\amd64\DIFxAPI.dll
9/21/2015 7:13:07 PM [DEBUG] - Loaded library: C:\Users\John\Documents\SCP DS3\bin\DIFxApi\amd64\DIFxAPI.dll
9/21/2015 7:13:07 PM [INFO] - Microsoft Windows 10 Pro (6.2.9200.0 AMD64) detected
9/21/2015 7:13:07 PM [INFO] - Selected Win10 configuration
9/21/2015 7:13:10 PM [INFO] - Virtual Bus Created
9/21/2015 7:13:10 PM [INFO] - ENTER:  DriverPackageInstallW
9/21/2015 7:13:10 PM [INFO] - Looking for Model Section [SCProductions.NTamd64]...
9/21/2015 7:13:10 PM [INFO] - Installing INF file 'C:\Users\John\Documents\SCP DS3\bin\System\ScpVBus.inf' (Plug and Play).
9/21/2015 7:13:10 PM [INFO] - Could not open file C:\WINDOWS\System32\DriverStore\FileRepository\scpvbus.inf_amd64_21ca245c0e23d7a5\scpvbus.inf.
9/21/2015 7:13:10 PM [ERROR] - PnP Install failed.
9/21/2015 7:13:10 PM [INFO] - Attempting to rollback ...
9/21/2015 7:13:10 PM [INFO] - No devices to rollback
9/21/2015 7:13:10 PM [INFO] - RETURN: DriverPackageInstallW  (0x3EE)
9/21/2015 7:13:10 PM [DEBUG] - Preparing to load libwdi
9/21/2015 7:13:10 PM [INFO] - Running as 64-Bit process
9/21/2015 7:13:10 PM [DEBUG] - libwdi path: C:\Users\John\Documents\SCP DS3\bin\libwdi\amd64\libwdi.dll
9/21/2015 7:13:10 PM [DEBUG] - Loaded library: C:\Users\John\Documents\SCP DS3\bin\libwdi\amd64\libwdi.dll
9/21/2015 7:13:10 PM [INFO] - Device with specified VID (054C) and PID (0268) found, preparing driver installation...
9/21/2015 7:13:10 PM [INFO] - Driver "Ds3Controller_a1267838-2e72-4909-a9f5-356be0f313c4.inf" successfully created in directory "Driver"
9/21/2015 7:13:13 PM [INFO] - Installation result: WDI_SUCCESS
9/21/2015 7:13:13 PM [INFO] - Installed driver for DualShock 3 controller USB\VID_054C&PID_0268
9/21/2015 7:13:13 PM [ERROR] - Couldn't start service: System.InvalidOperationException: Cannot start service Ds3Service on computer '.'. ---> System.ComponentModel.Win32Exception: The dependency service or group failed to start
  --- End of inner exception stack trace ---
  at System.ServiceProcess.ServiceController.Start(String[] args)
  at ScpDriver.ScpForm.Start(String service) in d:\Development\C#\ScpServer\Source\ScpInstaller\ScpForm.cs:line 90
9/21/2015 7:13:13 PM [INFO] - Install Succeeded.
9/21/2015 7:13:13 PM [INFO] - [Reboot Required]
9/21/2015 7:13:13 PM [INFO] - -- Install Summary --
9/21/2015 7:13:13 PM [INFO] - SCP DS3 Service installed
9/21/2015 7:13:13 PM [INFO] - Bus Device installed
9/21/2015 7:13:13 PM [INFO] - DS3 USB Driver installed

So there are 2 errors in the installation. The first seems like a security issue where it fails to create the files for the plug and play device? And I have no idea what the second error is referring to. I launched ScpDriver.exe as an admin, and I checked via Properties for an unblock option but there was none.
Also the SpcMonitor displays the host address as a bunch of 0's, so it could partially be a hardware issue.
Any help would be greatly appreciated, thanks Smile
(09-18-2015, 09:03 AM)Nefarius Wrote: ...about the QuadStick...   I'll merge your suggested changes into the source.

Thank you for including the QuadStick. 

I finally was able to test the 1.5.5740.18577 release and the QuadStick installed and ran OK on 64-bit Windows 8.1.  I also tried it on a 32-bit Windows 7 VM and got a WDI_ERROR_NOT_FOUND error message.  Logs attached.


.xml   ScpDsxInstaller.log.xml (Size: 20,22 KB / Downloads: 393)
.xml   ScpDsxService.log.xml (Size: 15,38 KB / Downloads: 378)
(09-22-2015, 06:32 AM)QuadStick Wrote: Thank you for including the QuadStick. 

I finally was able to test the 1.5.5740.18577 release and the QuadStick installed and ran OK on 64-bit Windows 8.1.  I also tried it on a 32-bit Windows 7 VM and got a WDI_ERROR_NOT_FOUND error message.  Logs attached.

This has been fixed in the meantime, will be included in the next release.
Hi,
Let's see if someone is able to help me.

My controller works perfectly with SCP, however it only works the first time I install the drivers. If I reboot or put the computer to sleep, the controller doesn't work anymore. If I uninstall and reinstall the driver, it works again until the next reboot.

Any clue on what is going on? Maybe the driver fails to initialize on boot? or the dongle is not fully supported?

My DS3 controller is supposed to be supported, I have this one:
HID\VID_054C&PID_0268&REV_0100 (by the way, the controller is from Sony, not Bigben, don't know why scp detects it as fake controller)

The bluetooth dongle seems to work fine also until reboot. I have this one (integrated):
USB\VID_8087&PID_07DC&REV_0001

My OS is Win 10 x64

Any help would be truly appreciated Smile

Thanks!
is there any information needed that i can provide to get the panhai conteroler to work?
(09-22-2015, 07:59 AM)overcloker55 Wrote: is there any information needed that i can provide to get the panhai conteroler to work?

You can help me test the attached BETA release containing attempts to support those. Tests and feedback from other PANHAI users greatly appreciated!


Attached Files
.7z   ScpServer_BETA_v1.5.5743.12430.7z (Size: 6,67 MB / Downloads: 254)




Users browsing this thread: 5 Guest(s)