..:: PCSX2 Forums ::..

Full Version: XInput Wrapper for DS3 and Play.com USB Dual DS2 Controller
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508
My controller just turns off when I remove the cable If it is paired to any address, can anybody help?

A video showing the problem:




My log:
Code:
2015-04-14 06:02:22.290 ++ C:\Program Files\Scarlet.Crush Productions\ScpService.exe 1.2.2.175
2015-04-14 06:02:22.310 ++ C:\Program Files\Scarlet.Crush Productions\ScpControl.dll 1.2.2.175
2015-04-14 06:02:22.479 ++ Microsoft Windows 7 Ultimate Service Pack 1 (6.1.7601.65536 AMD64)
2015-04-14 06:02:22.483 -- Bus Open   : Offset 0
2015-04-14 06:02:22.492 -- Bus Open   : Path \\?\ROOT#SYSTEM#0002#{F679F562-3164-42CE-A4DB-E7DDBE723909}
2015-04-14 06:02:22.592 ## Mapper.Initialize() - Profiles [5] Active [Default] Mappings [0]
2015-04-14 06:02:22.652 -- Bluetooth  : L2CAP_Worker_Thread Starting [82,02]
2015-04-14 06:02:22.664 -- Bluetooth  : HCI_Worker_Thread Starting [81]
2015-04-14 06:02:22.672 << HCI_Reset [0C03]
2015-04-14 06:02:22.724 >> HCI_Command_Complete_EV [0E] [00] [HCI_Reset]
2015-04-14 06:02:22.976 << HCI_Read_BD_ADDR [1009]
2015-04-14 06:02:22.976 >> HCI_Command_Complete_EV [0E] [00] [HCI_Read_BD_ADDR]
2015-04-14 06:02:22.986 << HCI_Read_Buffer_Size [1005]
2015-04-14 06:02:22.986 >> HCI_Command_Complete_EV [0E] [00] [HCI_Read_Buffer_Size]
2015-04-14 06:02:22.986 -- 02A0, 80, 0003, 0002
2015-04-14 06:02:22.996 << HCI_Read_Local_Version_Info [1001]
2015-04-14 06:02:22.996 >> HCI_Command_Complete_EV [0E] [00] [HCI_Read_Local_Version_Info]
2015-04-14 06:02:22.996 -- Master 00:15:83:15:A3:10, HCI_Version 3.0C5C, LMP_Version 3.0C5C
2015-04-14 06:02:23.006 << HCI_Write_Scan_Enable [0C1A]
2015-04-14 06:02:23.006 >> HCI_Command_Complete_EV [0E] [00] [HCI_Write_Scan_Enable]
2015-04-14 06:02:23.345 -- Controller : UDP_Worker_Thread Starting
2015-04-14 06:02:32.172 ++ Notify [Arrival] [{E2824A09-DBAA-4407-85CA-C8E8FF5F6FFA}] [\\?\USB#VID_054C&PID_0268#5&17D68890&0&1#{E2824A09-DBAA-4407-85CA-C8E8FF5F6FFA}]
2015-04-14 06:02:32.172 -- DS3 Arrival Event
2015-04-14 06:02:32.229 -- Device Arrival [38:C0:96:47:43:22]
2015-04-14 06:02:32.244 -- Bus Plugin : Serial 1
2015-04-14 06:02:32.244 ++ Plugin Port #1 for [38:C0:96:47:43:22]
2015-04-14 06:02:32.278 -- Started Device Instance [USB\VID_054C&PID_0268\5&17D68890&0&1] Local [38:C0:96:47:43:22] Remote [00:15:83:15:A3:10]
2015-04-14 06:02:32.286 -- USB Device : HID_Worker_Thread Starting
2015-04-14 06:02:42.371 ++ Notify [Removal] [{E2824A09-DBAA-4407-85CA-C8E8FF5F6FFA}] [\\?\USB#VID_054C&PID_0268#5&17D68890&0&1#{E2824A09-DBAA-4407-85CA-C8E8FF5F6FFA}]
2015-04-14 06:02:42.371 -- Device Removal [38:C0:96:47:43:22]
2015-04-14 06:02:42.375 -- USB Device : HID_Worker_Thread Exiting
2015-04-14 06:02:42.574 >> HCI_Connection_Request_EV [04]
2015-04-14 06:02:42.584 << HCI_Delete_Stored_Link_Key [0C12]
2015-04-14 06:02:42.594 << HCI_Remote_Name_Request [0419]
2015-04-14 06:02:42.594 >> HCI_Command_Complete_EV [0E] [00] [HCI_Delete_Stored_Link_Key]
2015-04-14 06:02:42.594 >> HCI_Command_Status_EV [0F] [00] [HCI_Remote_Name_Request]
2015-04-14 06:02:42.624 >> HCI_Remote_Name_Request_Complete_EV [07]
2015-04-14 06:02:42.624 -- Remote Name : 38:C0:96:47:43:22 - PLAYSTATION(R)3 Controller
2015-04-14 06:02:42.634 << HCI_Accept_Connection_Request [0409]
2015-04-14 06:02:42.634 >> HCI_Command_Status_EV [0F] [00] [HCI_Accept_Connection_Request]
2015-04-14 06:02:42.876 >> HCI_Role_Change_EV [12]
2015-04-14 06:02:42.886 >> HCI_Connection_Complete_EV [03]
2015-04-14 06:02:52.891 >> L2CAP_Connection_Request [02] PSM [11]
2015-04-14 06:02:52.901 << L2CAP_Connection_Response [03]
2015-04-14 06:02:52.901 << L2CAP_Configuration_Request [04]
2015-04-14 06:02:52.901 >> L2CAP_Configuration_Request [04]
2015-04-14 06:02:52.911 << L2CAP_Configuration_Response [05]
2015-04-14 06:02:52.911 >> L2CAP_Configuration_Response [05]
2015-04-14 06:02:52.931 >> L2CAP_Connection_Request [02] PSM [13]
2015-04-14 06:02:52.931 << L2CAP_Connection_Response [03]
2015-04-14 06:02:52.931 << L2CAP_Configuration_Request [04]
2015-04-14 06:02:52.941 >> L2CAP_Configuration_Request [04]
2015-04-14 06:02:52.941 << L2CAP_Configuration_Response [05]
2015-04-14 06:02:52.941 >> L2CAP_Configuration_Response [05]
2015-04-14 06:02:52.953 << L2CAP_Connection_Request [02] PSM [01]
2015-04-14 06:02:52.960 >> L2CAP_Connection_Response [03] [01]
2015-04-14 06:02:52.960 >> L2CAP_Connection_Response [03] [00]
2015-04-14 06:02:52.960 << L2CAP_Configuration_Request [04]
2015-04-14 06:02:52.970 >> L2CAP_Disconnection_Request [06] Handle [0050]
2015-04-14 06:02:52.970 << L2CAP_Disconnection_Response [07]
2015-04-14 06:02:52.970 >> L2CAP_Disconnection_Request [06] Handle [004F]
2015-04-14 06:02:52.970 << L2CAP_Disconnection_Response [07]
2015-04-14 06:02:52.980 >> L2CAP_Configuration_Response [05]
2015-04-14 06:02:52.980 >> L2CAP_Configuration_Request [04]
2015-04-14 06:02:52.980 << L2CAP_Configuration_Response [05]
2015-04-14 06:02:53.074 << L2CAP_Disconnection_Request [06]
2015-04-14 06:02:53.074 >> L2CAP_Disconnection_Response [07]
2015-04-14 06:02:53.084 ++ Plugin Port #1 for [38:C0:96:47:43:22]
2015-04-14 06:03:23.244 >> HCI_Disconnection_Complete_EV [05]
I'm having an issue which I believe I'm not the only one: using a dualshock 3/sixaxis, the buttons don't respond to the weakest commands. It happens both with the analog sticks and with the pressure sensitive buttons and as I start to slowly move or press them, the minimal value shown at that test section is around 600. Specifically for the analog sticks, it takes a lot of movement for them to send a message to the software. The result is I'm still unable to play MGS2 or 3 properly. Has anyone had a similar issue? I'm on Windows 8.1 and using USB.

I swear I've searched through a lot of the pages of the thread, but couldn't find anything like this. Thanks for anyone who answers me. o/
Greetings,
First I want to thank SC Productions for this great program. It really is a savior compared to MJ or betterDS3!

You see, I have this weird issue, my pad is functioning with BT but not with cable. I scrolled through most of the posts but didn't find any similar problem/solution. My OS is Vista SP2 by the way.

I tried doing a clean install(removed any other gamepad drivers, installed everything properly but every time it's the same, the BT is working as it should but with the cable or wired while on bluetooth mode the monitor says reserved and nothing happens.

Thanks for any reply in advance. I hope there is a fix to this other than installing windows 7/8.1
(04-14-2015, 06:22 PM)lzalru Wrote: [ -> ]I'm having an issue which I believe I'm not the only one: using a dualshock 3/sixaxis, the buttons don't respond to the weakest commands. It happens both with the analog sticks and with the pressure sensitive buttons and as I start to slowly move or press them, the minimal value shown at that test section is around 600. Specifically for the analog sticks, it takes a lot of movement for them to send a message to the software. The result is I'm still unable to play MGS2 or 3 properly. Has anyone had a similar issue? I'm on Windows 8.1 and using USB.

I swear I've searched through a lot of the pages of the thread, but couldn't find anything like this. Thanks for anyone who answers me. o/

Mine had a similar issue, but not as badly. Try doing calibration on the gamepads. When you do, be sure to push lightly on all the buttons so that the calibration tool will try to amplify the inputs. Of course, make sure calibrate the thumbsticks as you normally would or they will be hard to use. It will take a few times to get it right probably. The calibration tool is joy.cpl

Hope that helps.
This will probably be ignored by most people, but I might as well write it down while I am thinking about it. For starters, I have no affiliation with Scarlet.Crush and I am just temporarily working on this for the good of the community, as well as for myself. Second, I am also working on getting these working for Linux as well, so forgive me if I get confused as to which operating system people are using. I mostly use Linux myself, so some of the stuff I say may be coming from Linux rather than Windows. I will try to keep things straight, but the line gets fuzzy sometimes.
(04-14-2015, 06:58 PM)RayfenWindspear Wrote: [ -> ]Mine had a similar issue, but not as badly. Try doing calibration on the gamepads. When you do, be sure to push lightly on all the buttons so that the calibration tool will try to amplify the inputs. Of course, make sure calibrate the thumbsticks as you normally would or they will be hard to use. It will take a few times to get it right probably. The calibration tool is joy.cpl

Hope that helps.

Thanks a lot for the reply, man. Unfortunately, I had already tried it, but it didn't work. It seems that my buttons have a high threshold. Also, the calibration tool is focused on the analog sticks and triggers, it didn't help with the directional and the four buttons (square, triangle...). Is it just me who have this problem?
Hey there, I've been having this issue ever since I updated my drivers, and I've searched the high seas and a million questionable forums for a fix, but I can't seem to find anything about it.

Whenever I install the drivers for my Dualshock 3 Controller, it makes it so my headset microphone is disabled, and when I enter the "Sound" tab, it freezes itself, until I uninstall the drivers for the controller, that is.

Is there any known fix for this? It makes me want to cry into my pillow knowing that I can't play games on my PS3 Controller and talk at the same time.
(04-15-2015, 12:29 AM)xZaniity Wrote: [ -> ]Hey there, I've been having this issue ever since I updated my drivers, and I've searched the high seas and a million questionable forums for a fix, but I can't seem to find anything about it.

Whenever I install the drivers for my Dualshock 3 Controller, it makes it so my headset microphone is disabled, and when I enter the "Sound" tab, it freezes itself, until I uninstall the drivers for the controller, that is.

Is there any known fix for this? It makes me want to cry into my pillow knowing that I can't play games on my PS3 Controller and talk at the same time.

The SCPDriver disables all Bluetooth. If your headset is BT, it will not work on your PC with the SCPDriver installed. You are correct that BT works again when uninstalling the driver. There is no fix that would enable both SCP and the BT drivers to work simultaneously. The one thing you could do to get your headset working again is to use two BT dongles; in affect keeping the SCPDriver installed on our current BT, and having the new dongle act as the connection for non SCP devices such as the headset. If your headset is wired or works on the 2.4ghz wireless frequency, I'm not sure what is causing it to malfunction.
Can anyone explain to me how to use xinput wrapper with pinnacle game profiler? I want to use it with GW2. In device manager, my ps3 controller is listed as an xbox 360 peripheral and within PGP during controller setup all the buttons register properly, but for some reason it won't feed the commands to the game client. I feel like I have tried everything and cannot get it to work. Any help would be greatly appreciated, thank you!
I have a weird problem. I've been using the USB BT-211 on Windows 8.1 x64 for quite some time now. Now I know there is some Windows update that screws up the driver and makes the BT-211 incompatible, I've experienced it a couple times. Now I did a fresh install of Windows recently and it was working fine. Went to try it again and its not working. Also trying to reinstall the BT-211 driver it says its incompatible. Windows is not set to install any updates nor did it have any installed when I checked the install history. What can I do to get this to work again, I don't want to reinstall windows that's a pain even on a SSD cuz I have a lot of programs. Any help is appreciated, thanks
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508