..:: PCSX2 Forums ::..

Full Version: XInput Wrapper for DS3 and Play.com USB Dual DS2 Controller
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509
(08-05-2013, 07:47 AM)IncapsulatedThought Wrote: [ -> ]I've been having this same exact problem as of late. It's becoming a nuisance to reboot my computer every time I want to use my DS3 as a DS3. In the meantime, I just switched drivers for my controller since the lilypad scp keeps disconnecting, but having to reconfigure all of my games will become a hassle shortly.
I think I figured it out. I was going through a USB hub, when I connected directly to the computer I had no more problems.
This would be entirely perfect if I was able to easily switch L1/R1 with L2/R2 for comfort and easier trigger access.
(08-06-2013, 04:21 AM)Sneaka Wrote: [ -> ]Hey guys! I got my DS3 to work via USB but have not had any luck with my bluetooth dongle. I've followed the instructions to a T to no avail. Under SCP DS3 Monitor, the Host Address is showing Disconnected. A question... do all bluetooth dongles come with more than one hardware ID? When I check the Hardware IDs, I get the following listed:

USB\VID_0A5C&PID_21E8&REV_0112
USB\VID_0A5C&PID_21E8


The bottom one is listed in the "Supported" IDs. I'm a bit lost.

*Edit* Attaching log as it seems like that is needed. Hope I can get this situated. Cheers!


I have the same issue (exact same bluetooth dongle). It looks like our revision/version isn't supported yet though, so we'll just have to be patient. Other than that this solution works wonders, and is just plain better than MotioninJoy. Thanks for your hard work Scarlet!

Edit: I got it working. It seems in Win7x64 you need to use "force install" to get the Bluetooth driver installed. So, the steps I followed:

1: Follow all directions on the first page through step 5
2: Make sure your DS3 and Bluetooth dongle are connected
3: On Windows 7 64-bit with the VID_0AEC&PID_REV_0112 device id, DO check the "Force Install" box
4: Check to see that the DS3 has connected (Devices & Printers > XBOX360 Controller > properties)
5: Use the L1 + L2 + PS button to disconnect
6: Unplug the DS3
7: Turn on DS3 as usual, it should now pair w/ the bluetooth dongle


I may have used extra steps, but this is what worked for me. Hope this helps anyone who is having this problem!
(08-06-2013, 07:14 PM)GingerVitas Wrote: [ -> ]I have the same issue (exact same bluetooth dongle). It looks like our revision/version isn't supported yet though, so we'll just have to be patient. Other than that this solution works wonders, and is just plain better than MotioninJoy. Thanks for your hard work Scarlet!

Edit: I got it working. It seems in Win7x64 you need to use "force install" to get the Bluetooth driver installed. So, the steps I followed:

1: Follow all directions on the first page through step 5
2: Make sure your DS3 and Bluetooth dongle are connected
3: On Windows 7 64-bit with the VID_0AEC&PID_REV_0112 device id, DO check the "Force Install" box
4: Check to see that the DS3 has connected (Devices & Printers > XBOX360 Controller > properties)
5: Use the L1 + L2 + PS button to disconnect
6: Unplug the DS3
7: Turn on DS3 as usual, it should now pair w/ the bluetooth dongle


I may have used extra steps, but this is what worked for me. Hope this helps anyone who is having this problem!

You sir, are a Godsend! Thank you for this. I can confirm that it worked. All I had to do was check the Force Install box as you stated and reinstall the drivers. Thanks again! Cheers!!
Hi all. Having a slight issue, probably and hopefully a quick fix.


Running 64-bit Windows 8, using a Sony DS3 controller. Installed the drivers, followed the OP to the letter. DS3 controller connects to the 'second pad' I think you call it, and my games simply won't recognise that I have a controller connected. When connected to the BT, the 2nd LED is lit. Controller calibrates fine, just isn't connected to the right pad. Any help would be much appeciated. Smile
(08-06-2013, 06:29 AM)AzHP Wrote: [ -> ]I think I figured it out. I was going through a USB hub, when I connected directly to the computer I had no more problems.

I'm connected directly to my computer through the front usb ports. I'll try another port the back ports on the motherboard and see if I have anymore issues.

edit: Turns out, the usb port I was connected to is far looser than the rest of my ports, so a bad port could simply be the problem. I'll test your method and see if I continue to have issues.
I've been really trying to get this driver to work on laptop but I just can't seem to get it to work. Any help would be amazing as this looks like the best option when it is working.

I have the Asus BT211 dongle and a PS3 Sixaxis on a Win 7 32 bit machine.
When I plug in the controller, the lights on the controller blink for about a minute and then shut off.

When I look in Devices, the controller shows up as Playstation® 3 Controller

The SCP DS3 Monitor appears to be running but all 4 pads say disconnected

When I run ScpDriver.exe (the folder is copied to c:\ScpServer\bin\), this is the log I get:

INFO - ENTER: DriverPackageInstallW
INFO - Looking for Model Section [SCProductions.NTx86]...
INFO - RETURN: DriverPackageInstallW (0x103)
INFO - ENTER: DriverPackageInstallW
INFO - Looking for Model Section [SCProductions.NTx86]...
INFO - RETURN: DriverPackageInstallW (0x103)
INFO - ENTER: DriverPackageInstallW
INFO - Looking for Model Section [SCProductions.NTx86]...
INFO - RETURN: DriverPackageInstallW (0x103)

Install Succeeded.

-- Install Summary --

This is after trying to install it a whole bunch of times. I used to get other details with some things saying "Success".

I've tried uninstalling and reinstalling the Xbox 360 Accessories drivers.

I'm not sure what else to try. Any suggestions?
Just as an update, I tried uninstalling everything and reinstalling the bluetooth drivers and the xbox 360 controller drivers and then reinstalled SCP DS3 and this was the log I got:

SCP Bluetooth Driver Installer 1.0.0.103 [07/08/2013 8:33:53 PM]

Detected - Microsoft Windows 7 Professional Service Pack 1 (6.1.7601.65536 x86)
Selected WIN7 configuration.

SUCCESS - Virtual Bus Created
INFO - ENTER: DriverPackageInstallW
INFO - Looking for Model Section [SCProductions.NTx86]...
INFO - Installing INF file 'C:\ScpServer\bin\System\ScpVBus.inf' (Plug and Play).
INFO - Looking for Model Section [SCProductions.NTx86]...
INFO - Installing devices with Id "root\ScpVBus" using INF "C:\Windows\System32\DriverStore\FileRepository\scpvbus.inf_x86_neutral_21ca245c0e23d7a5\scpvbus.inf".
INFO - ENTER UpdateDriverForPlugAndPlayDevices...
SUCCESS - RETURN UpdateDriverForPlugAndPlayDevices.
INFO - Installation was successful.
SUCCESS - Install completed
INFO - RETURN: DriverPackageInstallW (0x0)
INFO - ENTER: DriverPackageInstallW
INFO - Looking for Model Section [SCProductions.NTx86]...
INFO - Installing INF file 'C:\ScpServer\bin\System\BthWinUsb.inf' (Plug and Play).
INFO - Looking for Model Section [SCProductions.NTx86]...
INFO - Installing devices with Id "USB\VID_0B05&PID_1783&REV_0001" using INF "C:\Windows\System32\DriverStore\FileRepository\bthwinusb.inf_x86_neutral_20bd213ec24c27eb\BthWinUsb.inf".
INFO - ENTER UpdateDriverForPlugAndPlayDevices...
SUCCESS - RETURN UpdateDriverForPlugAndPlayDevices.
INFO - Installation was successful.
SUCCESS - Install completed
INFO - RETURN: DriverPackageInstallW (0x0)
INFO - ENTER: DriverPackageInstallW
INFO - Looking for Model Section [SCProductions.NTx86]...
INFO - RETURN: DriverPackageInstallW (0x103)

Install Succeeded.

-- Install Summary --
Bus Device
Bus Driver
Bluetooth Driver


---------------------------------

It still doesn't seem to pair and doesn't work by USB either. I don't even really care about the bluetooth at this point. Any suggestions?
I have a problem in Windows 8.1 where when I uninstall the drivers, I have to repair the regular bluetooth drivers manually. This is a problem for me because I install and uninstall frequently to be able to use my bluetooth mouse.
Hello,
I write to all of you again because I have a problem..
After not using the Xinput Wrapper for about a year for Dark Souls,
I decided to install it again for the same game, I have done all necessary steps (Uninstalled previous one, installed newest and of course before that I also uninstalled all unused drivers and such)

I did exactly the same thing as before, yet this time even though it worked, I seem to have a problem.

Everytime something hits me, or I do a critical attack, my controller vibrates, which is normal.
But everytime my controler vibrates, it disconnects for a time of half a second in which I cannot do anything in the game.
This is a very annoying problem.
And it seems I cannot disable vibrations in Dark Souls, although I would if I could.

The rumble options in SCPUser also seem to cause a disconnection for a while.

Its definitely not because of my controller or the cable.
Anyone help?
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509